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Warranty and liability 
 

Note The Application Examples are not binding and do not claim to be complete 
regarding the circuits shown, equipping and any eventuality. The Application 
Examples do not represent customer-specific solutions. They are only intended 
to provide support for typical applications. You are responsible for ensuring that 
the described products are used correctly. These Application Examples do not 
relieve you of the responsibility to use safe practices in application, installation, 
operation and maintenance. When using these Application Examples, you 
recognize that we cannot be made liable for any damage/claims beyond the 
liability clause described. We reserve the right to make changes to these 
Application Examples at any time without prior notice.  
If there are any deviations between the recommendations provided in these 
Application Examples and other Siemens publications – e.g. Catalogs – the 
contents of the other documents have priority. 

We do not accept any liability for the information contained in this document. 
Any claims against us – based on whatever legal reason – resulting from the use of 
the examples, information, programs, engineering and performance data etc., 
described in this Application Example shall be excluded. Such an exclusion shall 
not apply in the case of mandatory liability, e.g. under the German Product Liability 
Act (“Produkthaftungsgesetz”), in case of intent, gross negligence, or injury of life, 
body or health, guarantee for the quality of a product, fraudulent concealment of a 
deficiency or breach of a condition which goes to the root of the contract 
(“wesentliche Vertragspflichten”). The damages for a breach of a substantial 
contractual obligation are, however, limited to the foreseeable damage, typical for 
the type of contract, except in the event of intent or gross negligence or injury to 
life, body or health. The above provisions do not imply a change of the burden of 
proof to your detriment. 
Any form of duplication or distribution of these Application Examples or excerpts 
hereof is prohibited without the expressed consent of the Siemens AG. 

Security 
informa-
tion 

Siemens provides products and solutions with industrial security functions that 
support the secure operation of plants, systems, machines and networks. 
In order to protect plants, systems, machines and networks against cyber 
threats, it is necessary to implement – and continuously maintain – a holistic, 
state-of-the-art industrial security concept. Siemens’ products and solutions only 
form one element of such a concept. 
Customer is responsible to prevent unauthorized access to its plants, systems, 
machines and networks. Systems, machines and components should only be 
connected to the enterprise network or the internet if and to the extent necessary 
and with appropriate security measures (e.g. use of firewalls and network 
segmentation) in place.  
Additionally, Siemens’ guidance on appropriate security measures should be 
taken into account. For more information about industrial security, please visit 
http://www.siemens.com/industrialsecurity. 

Siemens’ products and solutions undergo continuous development to make them 
more secure. Siemens strongly recommends to apply product updates as soon 
as available and to always use the latest product versions. Use of product 
versions that are no longer supported, and failure to apply latest updates may 
increase customer’s exposure to cyber threats. 
To stay informed about product updates, subscribe to the Siemens Industrial 
Security RSS Feed under http://www.siemens.com/industrialsecurity. 

 

http://www.siemens.com/industrialsecurity
http://www.siemens.com/industrialsecurity
http://www.siemens.com/industrialsecurity
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Preface 

The aim of this document 

Typical PCS 7 systems have at least an ES (Engineering Station) on the PC side, 
one or more possibly redundant servers and several OS clients (Operator 
Stations). In addition to the maximum availability of process control and data 
acquisition, there is also the possibility of integrating program adjustments or 
expansions in the foreground, quickly and without affecting the current process. 

In contrast, small systems or stand-alone units often require very little maintenance 
after commissioning. To achieve high efficiency, there exists the requirement to 
get along with as few PC stations as possible. It therefore makes sense to utilize 
the rarely used ES as an OS in process mode. 

This document is intended to serve as a selection guide in the search for the ideal 
PC constellations in small systems. It compares various minimal configurations 
(up to a max of three PCs) in terms of their functionality. Since the corresponding 
PCS 7 configuration is not the main focus of the system documentation, here you 
can also find the necessary activities required for the installation in form of detailed 
step instructions. 

Key content 

The main focus lies in the following topics: 

 Configuration comparison regarding functionality 

 Activities for configuration, activation and maintenance of various 
configurations 
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1.1 ES/OS single-user system 
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1 Overview of the minimal configuration 
There are various constellations possible when utilizing the engineering station in 
process mode as an operator station or multiple operator stations with as few PCs 
as possible. The following versions were selected according to their feasibility and 
usefulness in the context of PCS 7. 

The configurations shown here also include descriptions of solutions with 
configurations that do not differ significantly from each other. 

In general, particular functionality criteria must be considered when using the 
engineering PC as an OS, because the OS project must be closed when 
performing certain activities. This will also be discussed in more detail below. 

 

1.1 ES/OS single-user system 

The smallest of all configurations only requires one PC station. 

ES/OS

 

 

Process mode / functionality 

Since version 6.1 of PCS 7, the OS project can also be compiled when the runtime 
is activated (change compilation). Thus, the operator and archiving functions are 
given permanently. 

 

Note The description and configuration instructions for this configuration can be found 
in chapter 3 "ES/OS single-user system". 

Alternatives / variations 

The complete SIMATIC PCS 7 BOX package is also a good alternative. 
It combines the AS, OS and ES in a compact PC system. A PROFIBUS interface 
is also integrated to connect the distributed process I/O. 

 

Note The ES/OS single-user system can also be extended with the functionality of the 
PCS 7 OS Web Server. You can find the corresponding instructions in chapter 7 
"Expansion with the PCS 7 OS Web Option". 



1 Overview of the minimal configuration 

1.2 ES/OS client and OS server 
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1.2 ES/OS client and OS server 

With an additional PC station as an OS server, the ES can be used as an OS 
client. This receives access to the data of the OS server in process mode and 
visualizes them. 
 

Terminal bus

OS ServerES/OS Client

 

 

Process mode / functionality 

In PCS 7, the OS server may be used for operator functions when not more than 
four OS clients are connected. In this example, if the server malfunctions, the 
complete OS functionality fails. Besides this, the OS client must be terminated for 
OS project changes occurring at a later stage. But the OS server keeps on working 
permanently when compiling/loading changes. 

 

Note The description and configuration instructions for this configuration can be found 
in chapter 4 "ES/OS client and OS server". 

 

Alternatives / variations 

An advantage of this configuration is the possibility to connect additional clients 
to the OS server in a relatively simple and inexpensive manner. 

 



1 Overview of the minimal configuration 

1.3 ES, Master OS and Standby OS 
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1.3 ES, Master OS and Standby OS 

Three PC stations are required for the PCS 7–compliant implementation of OS 
redundancy. Then, the ES fulfills exclusively engineering tasks and during 
operation it only serves for testing OS functions. 

PROFINET IE

OS MasterES OS Standby

COM-Cable

Terminal bus

Redundancy

 

 

Process mode / functionality 

Since the ES is not involved in the process mode, the operator functions of the two 
OS single stations are permanently available. The OS remains active, even during 
complete loading of project changes. The redundancy ensures mutual 
synchronization, both when online and after the failure of one of the two partners. 

The COM connection (RS 232 connecting cable) serves for the optimization of 
internal server to server communication. 

As from PCS 7 V7.0, a separate Ethernet connection (free on-board or additional 
network adapter) can be used for redundancy connection as an alternative to the 
COM connection.  
 

Note The description and configuration instructions for this configuration can be found 
in chapter 5 "ES, Master OS and Standby OS". 

 

Alternatives / variations 

For the low-maintenance systems primarily mentioned in this document, one can 
often omit having a permanently present ES when a temporary ES is rented for 
configuring, commissioning and project changes. 

In this example, the conceivable expansion with additional OS clients is not readily 
possible because the two OSs are not installed with a server operating system. 

 



1 Overview of the minimal configuration 

1.4 ES/Master OS and Standby OS 
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1.4 ES/Master OS and Standby OS 

In this configuration with two redundant OS single stations, one of the two stations 
also serves as a simultaneous ES, which saves the need for a separate third 
station. 

ES/OS Master OS Standby

COM-Cable

Terminal bus

Redundancy

 

 

Process mode / functionality 

In this example both PC stations work in process mode as redundant OS single 
stations that balance off each other both in operation and after a failure of one of 
the two partners. This is also relevant for later OS project changes, which require 
the Master OS to be exited. In this case, the Standby OS takes over the master 
role. It keeps on working permanently while compiling/loading changes and 
updates the redundancy partner after it returns. 

The COM connection (RS 232 connecting cable) is used to optimize the internal 
communication between the two OS single stations. 

As from PCS 7 V7.0, a separate Ethernet connection (free on-board or additional 
network adapter) can be used for redundancy connection as an alternative to the 
COM connection. For a complete loading, the runtime and OS must be turned off 
and closed on both stations. During this time, no OS functionalities are available. 

 

Note This configuration does not provide the entire PCS 7 functionality, since the 
design of the redundancy is done by means of WinCC tools. 

The appropriate restrictions during process mode and the differences in the 
system behavior can be found together with the description and configuration 
instructions in chapter 6 "ES/Master OS and Standby OS". 

 



1 Overview of the minimal configuration 

1.4 ES/Master OS and Standby OS 
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Alternatives / variations 

For a PCS 7–compliant implementation of OS redundancy, it is recommended to 
use three PC stations. With the change in the licensing scheme concept, PCS 7 
V8.0 will require the same amount of license packages for this. The implementation 
of redundancy with two PC stations is associated with some limitations 
(see chapter 6.1 "Configuration description") and only saves you one computer 
(hardware and Windows license), when compared to the PCS 7–compliant 
implementation with a separate ES and two redundant OS single stations 
(see chapter 1.3 "ES, Master OS and Standby OS"). 

 

Note The ES/OS single-user system can also be extended with the functionality of the 
PCS 7 OS Web Server. You can find the corresponding instructions in chapter 7 
"Expansion with the PCS 7 OS Web Option". 

 



2 General/optional system settings 

2.1 Bus connection of the PC stations 
 

PCS 7 Minimal Configuration 
Entry ID: 24023824,    V6.0,    06/2016   11 
 


 S

ie
m

e
n

s
 A

G
 2

0
1

6
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

2 General/optional system settings 
The system settings relevant for configuration are proposed in the following 
section. 

2.1 Bus connection of the PC stations 

System bus 

In the ES as well as in each server, a network card is used in "Configured mode" 
for the system bus. On this network card, only the ISO protocol is enabled 
for Windows. If a CP1623 exists, it is used for access to the system bus. 
The parameter assignment is done in SIMATIC NetPro and in the HW Config. 

Terminal bus 

Except for the configuration with only one ES/OS single-user system, all other PC 
stations are otherwise also linked to the terminal bus. The required second network 
card by the ES and the server is here set to "PG mode". This card is not configured 
in SIMATIC NetPro and in the HW Config PCS 7 finds this network access via the 
computer name or the specified path for the target machine that needs to be 
entered in the object properties of the PC station. For this network card, only the 
TCP/IP protocol (no ISO) is activated in Windows. 

Client PC stations are generally equipped with only one network card, with which 
they are connected to the terminal bus. For this network card, only the TCP/IP 
protocol (no ISO) is activated in Windows. 

 

 

2.2 Autostart of WinCC 

The step instructions in this document specify that the OS project is opened in 
WinCC Explorer of the OS servers and clients for the purpose of activating the 
runtime. 

This should be mostly avoided in the system, since there are generally no 
configuration licenses (RC licenses) on the OSs. If the WinCC Explorer is open for 
longer than two hours, WinCC switches to Demo mode and must be completely 
closed (incl. runtime) and reopened for further configuration steps. 

To activate the runtime automatically when the computer starts without having to 
open WinCC explorer, one can configure an automatic start for the project. 

In conjunction with SIMATIC NET 2005 Edition (as from WinCC V6.0 SP3), the 
WinCC tool "AutoStartRT" should be configured in "Set configuration console PC 
station" in order to configure the WinCC automatic start: 

https://support.industry.siemens.com/cs/ww/en/view/23061262 

https://support.industry.siemens.com/cs/ww/en/view/23061262


3 ES/OS single-user system 

3.1 Configuration description 
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3 ES/OS single-user system 

3.1 Configuration description 

The single-user system is the smallest possible configuration. Both the ES and the 
OS functionalities are provided by the same PC. 

Hardware assembly 

ES/OS

Plant bus

AS

 

 

PCS 7 configuration 

 



3 ES/OS single-user system 

3.2 Required hardware and software licensing 
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3.2 Required hardware and software licensing 

Hardware 

The following hardware is recommended for this configuration and can be ordered 
via the Siemens mall. Your selected operating system and SIMATIC PCS 7 system 
software is preinstalled on the PC station in its relevant scope. 

 

Station Product label Operating 
system 

System bus transition 

1 x ES/OS SIMATIC PCS 7 ES/OS IPC847D BCE Windows 7 RJ45 network card 

SIMATIC PCS 7 ES/OS IPC847D IE Windows 7 CP1623 

 

Software licensing 

The following section lists the software/license package required for this 
configuration selection. 

In the selected configuration as a single-user system, the number of POs is limited 
to a maximum of 2000 units. 

 

Component Software/licence package 

ES/OS  SIMATIC PCS 7 ES Single Station (incl. 250 AS/OS runtime PO) 

 SIMATIC PCS 7 AS runtime licence 

 SIMATIC PCS 7 OS runtime licence (max. 2000 PO) 
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3.3 Step-by-Step configuration 
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3.3 Step-by-Step configuration 

Note The following instructions have been created based on Windows 7 and PCS 7 
V8.2. 

A CP1623 is used as an example for the system bus transition. 

3.3.1 ES configuration 

Creating the multiproject 

As a basis for the following instructions, the station must be physically connected 
according to the chart in chapter 3.1 (page 12). A multiproject must be also created 
on the ES, where the hardware and software of the AS are already configured. 

 

Creating a PC station 

The PC station is created in the PCS 7 project the PC station that represents both 
the ES and the OS. 

 

Step Activity Screenshot 

1.  Open the shortcut menu of the project in 
the component view and add a new PC 
station via "Insert New Object > SIMATIC 
PC station". 

Change the name of the PC station to 
match the name of the local computer on 
the network. 

 

2.  Open the HW Config of the PC station via 
the shortcut menu. 

 



3 ES/OS single-user system 

3.3 Step-by-Step configuration 
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Step Activity Screenshot 

3.  From the object catalog (View > Catalog) 
insert a  
"WinCC application" and a network card of 
the type "CP1623". 

 

4.  Select the system bus from "Subnet" or set 
this by pressing the "New..." button. 

Assign the corresponding MAC address to 
the CP1623. 

Deactivate the check box  
"IP protocol is being used". 

Click the "OK" button to confirm the 
settings. 

 

5.  Save and compile the configuration via the 
menu command: 
"Station > Save and compile..." 

Close the HW Config 
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3.3 Step-by-Step configuration 
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Configuring the PC station 

The function "Configure PC station" transfers project configurations to one or more 
target stations. 

 

Step Activity Screenshot 

1.  Configure the Station Configuration Editor 
of the ES. To do this, select the PC station 
of the ES and then choose  
"PLC > Configure..." in the shortcut menu. 

 

2.  Select the PC to be configured from 
"Accessible computers:". 

 

NOTE 

If you have chosen the option "Identical PC 
name 
PC station name" via "Object properties", 
the target PC to be configured appears 
directly in the component configurator. 

 

Use the "Show" button to display the 
current configuration of the PC station. 

Click on the  
"Configure…" button. 
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Step Activity Screenshot 

3.  In the window that appears you will see 
how the PC station is configured. 

Click the "OK" button to confirm this. 

 

4.  Confirm the information dialog by clicking 
the "OK" button. 

 

5.  In the bottom window you will then see the 
message: "Transfer completed 
successfully." 

Close the configuration dialog. 
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Configuring and loading AS-OS communication 

In the following section, the connection is configured with NetPro and loaded in the 
stations. 

 

Note In case of a granular station configuration, the subnets of the individual sub-
projects must be first merged. 

 

Step Activity Screenshot 

1.  Open NetPro. 

Select the WinCC application of the ES 
and open the shortcut menu. Select "Insert 
New Connection". 

 

2.  Select the CPU of the AS in the  
"Connection Partner" window. 

Make sure that an "S7 connection" is 
selected under "Connection". 

Click the "OK" button to confirm the 
selection. 
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Step Activity Screenshot 

3.  Under "Connection identification" in the 
"General" tab, change the "Local ID:" to a 
descriptive name, such as AS1. 

Click the "OK" button to confirm the entry. 

 

4.  Save and compile via 
:"Network > Save and Compile...". 

Select "Compile and check everything". 

Click the "OK" button to confirm the 
selection. 

 

5.  Select the ES and download the 
connection via the shortcut menu: 
"Download to current project > Selected 
Stations". 

Download the AS in the same way. 

Then close NetPro. 

 

 

Compiling and loading the user program 

Compile the S7 program and download it to the AS. 

 

Compiling the OS project 

Compile the OS project in SIMATIC Manager. 

 



3 ES/OS single-user system 

3.3 Step-by-Step configuration 
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3.3.2 OS configuration 

Step Activity Screenshot 

1.  Open the OS project. 

Select the OS project in the open WinCC 
Explorer and select "Properties" in the 
shortcut menu. 

 



3 ES/OS single-user system 

3.3 Step-by-Step configuration 
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Step Activity Screenshot 

2.  Select "Single-user project" in the 
"General" tab under "Type:". 

Confirm your selection and the displayed 
message by clicking the "OK" button. 

 

 

3.  In the "Options" tab, select the option 
"Allow activation on the ES ". 
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Step Activity Screenshot 

4.  Click on the "No" button, in order to 
prevent the deletion of the startup list. 

 

5.  Close the WinCC Explorer. 

 

NOTE 

Changes take effect only after closing and 
reopening the WinCC Explorer. 
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3.3.3 Activating the runtime 

After the OS project is closed, open it again and activate the runtime. 

 

3.3.4 Particularities when loading the OS project changes 

If the OS and ES are operated on a single PC, you have to perform a loading 
operation because all required data is already available. Here it's enough to run the 
"Compile OS" function. 

Just like the function "Download changes", you can run the function "Compile 
changes" in the single-user system without exiting the process mode on the OS. 
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4 ES/OS client and OS server 

4.1 Configuration description 

In a server-client structure with only two computers, the ES serves simultaneously 
as an OS client. 3 PCs should be provided in this configuration. 

 

ES/OS Client

Plant bus

OS Server

Terminal bus

AS

 

 

PCS 7 configuration 
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4.2 Required hardware and software licensing 

Hardware 

The following hardware is recommended for this configuration and can be ordered 
via the Siemens mall. This ensures that the appropriate amount of operating 
systems of your choice and SIMATIC PCS 7 system software are pre-installed on 
the PC stations. 

 

Station Product label Operating system System bus 
transition 

ES/OS client SIMATIC PCS 7 ES/OS IPC847D 
BCE 

Windows 7 RJ45 
network card 

SIMATIC PCS 7 ES/OS IPC847D IE Windows 7 CP 1623 

OS server SIMATIC PCS 7 ES/OS IPC847D 
BCE 

Windows Server 2008 R2 RJ45 
network card 

SIMATIC PCS 7 ES/OS IPC847D IE Windows Server 2008 R2 CP 1623 

 

Software Licensing 

The following section lists the software/license packages required for this 
configuration selection. 

An OS server can provide up to 12,000 POs with the corresponding software 
package, depending on the project size. In addition to engineering software, an OS 
client software must be also installed on the ES. 

 

Component Software/licence package 

ES/OS client  SIMATIC PCS 7 AS/OS Engineering Software V8.2 (PO unlimited) 

 SIMATIC PCS 7 AS Runtime License  

 SIMATIC PCS 7 OS Software Client V8.2 

OS server  SIMATIC PCS 7 OS Software Server V8.2 

 SIMATIC PCS 7 OS Runtime License (max. 12000 PO) 
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4.3 Step-by-Step configuration  

Note The following instructions have been created based on Windows 7 and 
PCS 7 V8.2. 

CP1623 are used as an example for the system bus transition. Time 
synchronization is activated. 

The PC stations used in the test setup are called: 

 ES/OS client: ESV81 

 OS server:     SV 

4.3.1 Preparatory activities 

Create a project folder on the OS server and enable it. This allows the OS data 
configured on the engineering station to be transferred to the OS server. 

 

4.3.2 ES configuration 

Creating the multiproject 

As a basis for the following instructions, all PC stations must be physically 
connected according to the chart in chapter 4.1 (page 24). A multiproject must be 
also created on the ES, where the hardware and software of the AS are already 
configured. 

Then you begin from the following CPU and CP settings. 
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AS settings 

This example describes a way in which the OS server predetermines the master 
time. 

 

Note More time synchronization possibilities are described in detail in the following 
manuals: 

 SIMATIC Process Control System PCS 7 Operator Station (V8.2)  

 SIMATIC Process Control System PCS 7 Time synchronization (V8.2) 

 

Step Activity Screenshot 

1.  Open the HW Config for the AS. 

Select the CPU and choose "Object 
properties..." in the shortcut menu. 

 

2.  Switch to the "Diagnostics/Clock" tab. 

In the "Clock" section, set "Synchronization 
Type - As slave". 

Click the "OK" button to confirm the 
selection. 

 

https://support.industry.siemens.com/cs/ww/en/view/109485970
https://support.industry.siemens.com/cs/ww/en/view/109485963
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Step Activity Screenshot 

3.  Open the shortcut menu of the CP and 
select "Object properties…". 

 

4.  Switch to the "Time synchronization" tab. 

Activate the check box "Accept time of day 
on CP and forward". 

Click the "OK" button to confirm the 
setting. 

 

5.  Save and compile the configuration via: 
"Station > Save and compile...". 

Close the HW Config 
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Setting up the ES PC station 

In order to test the OS project on the ES, create a PC station for the ES with the 
WinCC application. 

 

Step Activity Screenshot 

1.  Open the shortcut menu of the project in 
the component view and add a new PC 
station via "Insert New Object > SIMATIC 
PC station". 

Change the name of the PC station so that 
it matches the name of the local computer 
on the network. 

 

2.  Open the HW Config of the PC station 
via the shortcut menu. 

 

3.  From the object catalog ("View > Catalog") 
insert a "WinCC application" and a network 
card of the type "CP1623". 
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Step Activity Screenshot 

4.  Select the system bus from "Subnet" or set 
this by pressing the "New..." button. 

Assign the corresponding MAC address 
to the CP1623. 

Deactivate the check box "IP protocol is 

being used". 

Click the "OK" button to confirm the 
settings. 

 

5.  Open the shortcut menu of the CP1623 
and select "Object properties…". 

 

6.  Go to the "Options" tab and select the 
check box "Time of day". 

Click the "OK" button to confirm the 
selection. 

 

7.  Save and compile via the menu command: 
"Station > Save and compile...". 

Close the HW Config 

 

8.  

optional 

In SIMATIC Manager, delete the OS 
application of the ES PC station, as this 
is not needed in our example. 
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Setting up the OS server PC station 

Step Activity Screenshot 

1.  Open the shortcut menu of the project in 
the component view and add a new PC 

station via "Insert New Object > SIMATIC 

PC station". 

 

2.  Open the HW Config of the PC station via 
the shortcut menu. 

 

3.  From the object catalog ("View > Catalog") 
insert a "WinCC application" and a network 
card of the type "CP1623". 

 

4.  Select the system bus from "Subnet" or set 
this by pressing the "New..." button. 

Assign the corresponding MAC address to 
the CP1623. 

Deactivate the check box "IP protocol is 

being used". 

Click the "OK" button to confirm the 
settings. 
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Step Activity Screenshot 

5.  Open the shortcut menu of the CP1623 
and select "Object properties…". 

 

6.  Go to the "Options" tab and select the 
check box "Time of day". 

Click the "OK" button to confirm the 
setting. 

 

7.  Save and compile via the menu command: 
"Station > Save and compile...". 

Close the HW Config 

 

8.  In SIMATIC Manager, open the properties 
dialog of the OS server's OS project. 

Switch to the "Target OS and Standby OS 
Computer" tab. 

Select < none > under "Standby OS". 

Then click the "Search..." button. 
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Step Activity Screenshot 

9.  Navigate via the drop-down list to the 
shared project folder of the OS server 
(see 4.3.1 Preparatory activities). 

Click the "Save" button. 

 

10.  In the text box, select the path "Path to 
Target OS Computer". 

Click the "OK" button to confirm this. 

 

11.  Confirm the information dialog by clicking 
the "Yes" button. 
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Setting up the Client PC station 

Step Activity Screenshot 

1.  Open the shortcut menu of the project in 
the component view and add a new PC 
station via "Insert New Object > SIMATIC 
PC station". 

 

2.  Open the HW Config of the OS client's PC 
station. 

 

3.  From the object catalog (View > Catalog) 
insert a WinCC application client. 

 

4.  Save and compile via the menu command: 
"Station > Save and compile...". 

Close the HW Config 
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Step Activity Screenshot 

5.  In SIMATIC Manager, open the shortcut 
menu of the client's PC station and select 
"Object properties". 

 

6.  Under "PC name:" enter the name of the 
PC on which the operation of the client is 
intended. In the present configuration, this 
is the ES PC. 

Click the "OK" button to confirm the entry. 
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Configuring all relevant PC stations 

The function "Configure PC station" transfers project configurations to one or more 
target stations. First configure the local Station Configuration Editor of the ES and 
then the OS connected to the system bus. 

 

Step Activity Screenshot 

1.  Configure the Station Configuration Editor 
of the ES. To do this, open the shortcut 
menu of the ES and choose "PLC> 
Configure ...". 

 

2.  Select the PC to be configured from 
"Accessible computers:". 

 

NOTE 

If you have chosen the option "Identical PC 
name to PC station name" via "Object 
properties", the target PC to be configured 
appears directly in the component 
configurator. 

 

Use the "Show" button to display the 
current configuration of the PC station. 

Click on the "Configure…" button. 
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Step Activity Screenshot 

3.  In the window that appears you will 
see how the PC station is configured. 

Click the "OK" button to confirm this 
setting. 

 

4.  Confirm the information dialog by clicking 
the "OK" button. 

 

5.  In the bottom window you will then see 
the message: "Transfer completed 
successfully." 

Close the configuration dialog. 
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Step Activity Screenshot 

6.  Configure the Station Configuration Editor 
of the OS server as shown in steps 1 to 5. 

 

Configuring and loading AS-OS communication 

In the following section, the connections between the PC stations and the AS are 
configured in NetPro and loaded in the individual stations. 

 

Note In case of a granular station configuration, the subnets of the individual sub-
projects must be first merged. 

 

Step Activity Screenshot 

1.  Open NetPro. 

Select the WinCC application of the ES 
and open the shortcut menu. 
Select "Insert New Connection". 
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Step Activity Screenshot 

2.  Select the CPU of the AS in the 
"Connection Partner" window. 

Make sure that an "S7 connection" 
is selected under "Connection". 

Click the "OK" button to confirm the 
selection. 

 

3.   Under "Connection identification" in the 
"General" tab, change the "Local ID:"  
to a descriptive name, such as AS1. 

Click the "OK" button to confirm the 
entries. 

 

4.  Repeat steps 1 to 3 for the connection of 
the OS server to the AS. 

When doing this, it is important that the 
connections of the ES and the OS server 
to the AS have the same name. 

When ready, save and compile the 
configuration via the menu command: 
"Network > Save and Compile…". 

Select the option button "Compile and 
check everything" and confirm your 
selection with the "OK" button. 
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Step Activity Screenshot 

5.  Select the ES and download the 
connections via the shortcut menu: 
"Download to current project > Selected 
Stations". 

Download the OS server and the AS in 
the same way. 

Then close NetPro. 

 

 

Compiling and loading the user program 

Compile the S7 program and download it to the AS. 

 

Compiling the OS server project 

Compile the OS server project in SIMATIC Manager. 

Make sure to make the correct OS assignment to the server in the plant view. 
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Assignment of server packages 

Step Activity Screenshot 

1.  Select the OS application of the OS client 
and choose "Assign OS server..." in the 
shortcut menu. 

 

2.  Select the corresponding OS project and 
confirm your selection with the "OK" 
button. 

 

3.  Confirm successful downloading of 
the package with the "OK" button. 

 



4 ES/OS client and OS server 

4.3 Step-by-Step configuration 
 

PCS 7 Minimal Configuration 
Entry ID: 24023824,    V6.0,    06/2016   42 
 


 S

ie
m

e
n

s
 A

G
 2

0
1

6
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

 

4.3.3 OS configuration 

Activating the time synchronization 

On the ES, the necessary settings must still be activated in the OS projects of the 
OS server and OS client. 

 

Step Activity Screenshot 

1.  Open the OS server project. 
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Step Activity Screenshot 

2.  Open the editor "Time Synchronization" 
from the shortcut menu. 

 

Activate the check box "Synchronization 
via System Bus (Master, Slave)". 

Select "CP1623(ISO)" under "Access point 
1" and activate the option button "Master". 

Click the "OK" button to confirm the 
selection. 

 

NOTE 

If, in contrast to the OS server, the ES 
does not have a CP1623, then activate 
the option "Display symbolic name of the 
access point" and select the appropriate 
access point. 

 

3.  Close the OS server project.  

4.  Open the OS client project. 
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Step Activity Screenshot 

5.  Open the editor "Time Synchronization" 
from the shortcut menu. 

Activate the check box "Synchronization 
via Terminal Bus (Slave)" and select "Use 
the time from a connected WinCC server". 

Click the "OK" button to confirm the 
selection. 

 

6.  Close the OS client project.  
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Downloading the OS project to the OS server 

After the time synchronization is configured on the ES side, download the OS 
project to the OS server. 

 

Step Activity Screenshot 

1.  In SIMATIC Manager, select the OS 
project of the OS server and select 
the context menu "PLC > Download". 

 

2.  For the first OS project download, 
an entire download is required. 

Start the download by clicking the "OK" 
button. 
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Step Activity Screenshot 

3.  After a successful download, the OS 
project is located in the specified folder 
on the OS server. 

Click the "OK" button to confirm the 
corresponding message. 
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OS configuration on the OS server 

The following step instructions for time synchronization must be checked and 
corrected it if necessary after the first download. 

 

Note Normally, all the engineering work will be carried out on the ES for the purpose 
of consistent data management, so that no WinCC engineering licenses are 
required on the OSs. Nevertheless, each time the WinCC Explorer is opened, 
a licence-free time window of two hours is enabled for WinCC configuration 
works. 

 

Step Activity Screenshot 

1.  Open the OS project on the OS server.  

2.  Open the editor "Time Synchronization" 
from the shortcut menu. 

 

Check or activate the check box 
"Synchronization via System Bus 
(Master, Slave)". 

Check or select "CP1623(ISO)" and the 
option button "Master" under "Access 
point 1". 

 

Click the "OK" button to confirm the 
settings. 
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4.3.4 Activating the runtime 

Open the OS project on the OS server and activate the runtime. 

Then switch to the ES computer and open the OS client project. Activate the 
runtime here too. 

 

4.3.5 Particularities when loading the OS project changes 

Loading changes 

Before being able to carry out OS compiling and downloading to the ES, 
the OS client runtime must be first deactivated and the OS project closed. 

 

Complete download 

Before being able to carry out OS compiling and downloading from the ES, the OS 
client runtime and the OS server must be first deactivated and the corresponding 
OS projects must be closed. 
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5 ES, Master OS and Standby OS 

5.1 Configuration description 

 During the process mode, the pair of single stations runs completely parallel and 
independent from each other. If one of the single stations fails, there is always an 
equivalent, redundant OS single station available. The single stations monitor each 
other during the running period and synchronize the project archives as needed. 
Configuring is done via the ES. 

Hardware assembly 

OS Master

COM-Cable

Terminal bus

Plant bus

ES

AS

OS Standby

Redundancy

 

NOTE Server packages are necessary for the functionality of the MS clients. If the 
OS/MS Server is configured as single station it is not possible to use the MS 
client on the ES. 
The jumping keys in the asset faceplates to HW configuration and to PDM work 
as follows: 
 - Up to PDM V8.1: Only on ES 
 - From PDM V8.2: On ES and OS clients 
 - From PDM V9.0: On ES, OS clients and web clients 
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PCS 7 configuration 
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5.2 Required hardware and software licensing 

Hardware 

The following hardware is recommended for this configuration and can be ordered 
via the Siemens mall. This ensures that the appropriate amount of operating 
systems of your choice and SIMATIC PCS 7 system software are pre-installed 
on the PC stations. 

 

Station Product label Operating 
system 

System bus 
transition 

ES SIMATIC PCS 7 ES/OS IPC847D 
BCE 

Windows 7 RJ45 
network card 

SIMATIC PCS 7 ES/OS IPC847D 
IE 

Windows 7 CP 1623 

2 x OS Single Station  SIMATIC PCS 7 ES/OS IPC847D 
BCE 

Windows 7 RJ45 
network card 

SIMATIC PCS 7 ES/OS IPC847D 
IE 

Windows 7 CP 1623 

 

Software licensing 

The following section lists the software/license packages required for this 
configuration selection. 

 

Component Software/license package 

ES  SIMATIC PCS 7 AS/OS Engineering Software V8.2  
(PO unlimited) 

 SIMATIC PCS 7 AS Runtime License 
 

OS Single Station Redundant  SIMATIC PCS 7 OS Software Single Station 
Redundancy V8.2 (Single License for 2 installations) 

 2x SIMATIC PCS 7 OS Runtime License  
(max. 5000 PO)  
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5.3 Step-by-Step configuration 

Note The following instructions have been created based on Windows 7 and 
PCS 7 V8.2. 

CP1623 are used as an example for the system bus transition. Time 
synchronization is activated. 

The PC stations used in the test setup are called: 

 ES:      ESV81 

 OS server:    SVA 

 OS-Server Standby:  SVB 

5.3.1 ES configuration 

Creating the multiproject 

As a basis for the following instructions, all PC stations must be physically 
connected according to the chart in chapter 5.1. A multiproject must be also 
created on the ES, where the hardware and software of the AS are already 
configured. 
Then you begin from the following CPU and CP settings. 

AS settings 

The analyzability of the process data requires that all the components of the 
process control system work with an identical clock time in order to be able to 
assign messages in the correct temporal order. 

The following section describes a way in which the redundant OS single stations 
predetermine the master time. 

 

Note More time synchronization possibilities are described in detail in the following 
manuals: 

 SIMATIC Process Control System PCS 7 Operator Station (V8.2)  

 SIMATIC Process Control System PCS 7 Time synchronization (V8.2) 

 

https://support.industry.siemens.com/cs/ww/en/view/109485970
https://support.industry.siemens.com/cs/ww/en/view/109485963


5 ES, Master OS and Standby OS 

5.3 Step-by-Step configuration 
 

PCS 7 Minimal Configuration 
Entry ID: 24023824,    V6.0,    06/2016   53 
 


 S

ie
m

e
n

s
 A

G
 2

0
1

6
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

Step Activity Screenshot 

1.  Open the HW Config for the AS. 

Select the CPU and choose "Object 
properties..." in the shortcut menu. 

 

2.  Switch to the "Diagnostics/Clock" tab. 

In the "Clock" section, set "Synchronization 
Type - As slave". 

Click the "OK" button to confirm the 
selection. 
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Step Activity Screenshot 

3.  Open the shortcut menu of the CP and 
select "Object properties…". 

 

4.  Switch to the "Time synchronization" tab. 

Activate the check box "Accept time of day 
on CP and forward". 

Click the "OK" button to confirm the 
selection. 

 

5.  Save and compile the configuration via: 
"Station > Save and compile...". 

Close the HW Config 
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Setting up the ES PC station 

A PC station is created for the ES with the WinCC application to allow testing the 
OS project on the ES. 

 

Step Activity Screenshot 

1.  Open the shortcut menu of the project in 
the component view and add a new PC 
station via "Insert New Object > SIMATIC 
PC station". 

Change the name of the PC station so that 
it matches the name of the local computer 
on the network. 

 

2.  Open the HW Config of the ES PC station 
via the shortcut menu. 

 

3.  From the object catalog (View > Catalog) 
insert a "WinCC application" and a network 
card of the type "CP1623". 
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Step Activity Screenshot 

4.  Select the system bus from "Subnet" or set 
this by pressing the "New..." button. 

Assign the corresponding MAC address to 
the CP1623. 

Deactivate the check box "IP protocol is 
being used". 

Click the "OK" button to confirm the 
settings. 

 

5.  Open the shortcut menu of the CP1623 
and select "Object properties…". 

 

6.  Go to the "Options" tab and select the 
check box "Time of day". 

Click the "OK" button to confirm the 
selection. 

 

7.  Save and compile via the menu command: 
"Station > Save and compile...". 

Close the HW Config 

 

8.  

optional 

Delete the OS of the Engineering Station 
in SIMATIC Manager, as it is not needed 
in our example. 
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Setting up the Master OS PC station 

Step Activity Screenshot 

1.  Open the shortcut menu of the project in 
the component view and add a new PC 
station via "Insert New Object > SIMATIC 
PC station". 

 

2.  Open the HW Config of the Master OS PC 
station via the shortcut menu. 

 

3.  From the object catalog (View > Catalog) 
insert a "WinCC application" and a network 
card of the type "CP1623". 
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Step Activity Screenshot 

4.  Select the system bus from "Subnet" or set 
this by pressing the "New..." button. 

Assign the corresponding MAC address 
to the CP1623. 

Deactivate the check box "IP protocol is 
being used". 

Click the "OK" button to confirm the 
settings. 

 

5.  Open the shortcut menu of the CP1623 
and select "Object properties…". 

 

6.  Go to the "Options" tab and select the 
check box "Time of day". 

Click the "OK" button to confirm the 
selection. 

 

7.  Save and compile via the menu command: 
"Station > Save and compile...". 

Close the HW Config 
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Setting up the Standby OS PC station 

Step Activity Screenshot 

1.  Open the shortcut menu of the project in 
the component view and add a new PC 
station via "Insert New Object > SIMATIC 
PC station". 

 

2.  Open the HW Config of the Standby OS 
PC station via the shortcut menu. 

 

3.  From the object catalog (View > Catalog) 
insert a "WinCC application (Stby)" and 
a network card of the type "CP1623". 
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Step Activity Screenshot 

4.  Select the system bus from "Subnet" or set 
this by pressing the "New..." button. 

Assign the corresponding MAC address to 
the CP1623. 

Deactivate the check box "IP protocol is 
being used". 

Click the "OK" button to confirm the 
settings. 

 

5.  Open the shortcut menu of the CP1623 
and select "Object properties…". 

 

6.  Go to the "Options" tab and select the 
check box "Time of day". 

Click the "OK" button to confirm the 
setting. 

 

7.  Save and compile via the menu command: 
"Station > Save and compile...". 

Close the HW Config 
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Configuring all PC stations 

The function "Configure PC station" transfers project configurations to one or more 
target stations. First, configure the local ES and then all Operator Stations 
connected to the system bus. 

 

Step Activity Screenshot 

1.  Configure the Station Configuration 
Editor of the ES. To do this, select the 
PC station of the ES and then choose 
"PLC > Configure..." in the shortcut menu. 

 

2.  Select the PC to be configured from 
"Accessible computers:". 

 

NOTE 

If you have chosen the option "Identical PC 
name to PC station name" via "Object 
properties", the target PC to be configured 
appears directly in the component 
configurator. 

 

Use the "Show..." button to display the 
current configuration of the PC station. 

Click on the "Configure…" button. 
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Step Activity Screenshot 

3.  In the window that appears you will see 
how the PC station is configured. 

Click the "OK" button to confirm this 
setting. 

 

4.  Confirm the information dialog by clicking 
the "OK" button. 

 

5.  In the bottom window you will then see 
the message: 
"Transfer completed successfully." 

Close the configuration dialog. 
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Step Activity Screenshot 

6.  Configure the Station Configuration Editors 
of the Master/Standby OS as shown in 
steps 1 to 5. 

 

Configuring and loading AS-OS communication 

In the following section, the connections between the PC stations and the AS are 
configured in NetPro and loaded in the individual stations. 

 

Note In case of a granular station configuration, the subnets of the individual sub-
projects must be first merged. 

 

Step Activity Screenshot 

1.  Open NetPro. 

Select the WinCC application of the ES 
and open the shortcut menu.  
Select "Insert New Connection". 

 

2.  Select the CPU of the AS in the 
"Connection Partner" window. 

Make sure that an "S7 connection" 
is selected under  "Connection". 

In this example, a high-availability S7 
connection is configured due to the AS 
configuration. 

Click the "OK" button to confirm the 
selection. 
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Step Activity Screenshot 

3.  Under "Connection identification" in the 
"General" tab, change the "Local ID:" 
to a descriptive name, such as “AS1”. 

Click the "OK" button to confirm the 
settings. 

 

4.  Also set the connections of the Master OS 
and Standby OS to the AS by repeating 
steps 1 to 3. 

When doing this, it is important that the 
connections of the Master OS, Standby OS 
and ES to the AS have the same name. 

Then save and compile the configurations 
via the menu command: 
"Network > Save and compile...". 

 

Select the option button "Compile and 
check everything" and confirm your 
selection by clicking the "OK" button. 

 

5.  Select the ES and download the 
connection via the menu command: 
"Target system > Download to current 
project > Selected Stations". 

Download the AS, the Master OS and 
Standby OS in the same manner. 

Then close NetPro. 
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Master/Standby settings on the ES 

Here you define the Master/Standby assignment and create the loading paths. 

 

Step Activity Screenshot 

1.  In SIMATIC Manager, open the properties 
dialog of the Master OS. 

Switch to the "Target OS and Standby OS 
Computer" tab. 

Select the Standby OS from the drop-down 
list. 

Activate the check box "Create/update 
archive tags". 

Deactivate the check box "Transfer to 
external archive server". 

Click on the "Search..." button. 

 

2.  Navigate via the drop-down list to the 
shared project folder of the Master OS 
(see 4.3.1 Preparatory activities). 

Click the "Save" button. 
 

3.  In the text box, reselect the whole project 
path "Path to Target OS Computer". 

Click the "OK" button to confirm the entry. 

 

4.  Open the properties dialog of the Standby 
OS. 

Switch to the "Target OS and Mater OS 
Computers" tab. 

Check whether OS_Master is entered in 
the "Master OS" field. 

Click the "Search..." button to select the file 
path of the OS data. 
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Step Activity Screenshot 

5.  Navigate via the drop-down list to the 
shared project folder of the Standby OS 
(see 4.3.1 Preparatory activities). 

Click the "Save" button. 
 

6.  In the text box, select the path "Path to 
Target OS Computer". 

Click the "OK" button to confirm this. 

Confirm the next appearing dialog by 
clicking "Yes". 

 

 

Compiling and loading the user program 

Compile the S7 program and download it to the AS. 

 

Compiling the OS project 

Compile the OS project of the Master OS in SIMATIC Manager. 

Make sure to make the correct OS assignment to the server in the plant view. 
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5.3.2 OS configuration 

OS configuration on the engineering station 

On the ES, a conversion must be still done from a multi-user to a single-user 
system, and the settings for the redundancy and time synchronization must be still 
adjusted. 

 

Step Activity Screenshot 

1.  Open the OS project of the Master OS in 
the ES. 

Select the OS project in the open WinCC 
Explorer and select "Properties" in the 
shortcut menu. 
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Step Activity Screenshot 

2.  Under "Type" in the "General" tab, select: 
"Single-User Project". 

Confirm your entry and the displayed 
message by clicking the "OK" button. 

 

 

3.  Prevent deleting the startup list by clicking 
the "No" button. 

 



5 ES, Master OS and Standby OS 

5.3 Step-by-Step configuration 
 

PCS 7 Minimal Configuration 
Entry ID: 24023824,    V6.0,    06/2016   69 
 


 S

ie
m

e
n

s
 A

G
 2

0
1

6
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

Step Activity Screenshot 

4.  Open the "Redundancy" editor. 

 

Activate the "Default Master" option. 

Enter the Standby OS in the "Redundant 
partner server" field. 

Check whether your desired check boxes 
are activated under "Optional Settings". 

If you do not want to operate the RS 232 
redundancy cable on the COM1 interface, 
you must adjust this setting later yourself 
on the operator stations (see section "OS 
configuration on the Operator Station"). 

Click the "OK" button to confirm the 
settings. 

 

5.  Open the "Time Synchronization" editor. 

 

Activate the check box "Synchronization 
via System Bus (Master, Slave)". 

Select "CP1623(ISO)" under "Access point 
1" and activate the "Master" option. 

Activate the check box  
"Display symbolic name of the access 
point". 

Click the "OK" button to confirm the 
settings. 

 

NOTE 

If the ES does not have a CP1623, then 
activate the option "Display symbolic 
name of the access point" and select 
the appropriate access point. 

 

6.  Close the OS project.  
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Downloading the OS project to the OS computer 

Once the redundancy and time synchronization are configured on the ES, 
download the OS project to the Master OS and the Standby OS. 

 

Step Activity Screenshot 

1.  In SIMATIC Manager, select the Master 
OS and choose the following in the context 
menu: "PLC > Download". 

 

2.  For the first OS project download, an entire 
download is required. 

Start the download by clicking the "OK" 
button. 
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Step Activity Screenshot 

3.  After a successful download, the OS 
project is located in the specified folder 
on the Master OS. 

Click the "OK" button to confirm the 
corresponding message. 

 

4.  Repeat steps 1 to 3 to download the OS 
project to the Standby OS. 
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Configuring on the Operator Station 

If, as opposed to the operator station, the engineering station has no CP1623 or 
if the RS 232 redundancy cable is not connected to the COM1 port, the following 
step instructions must be carried out. Generally we advise you to check the project 
settings after the project has been downloaded to the target systems. 

 

Note Normally, all the engineering work will be carried out on the ES for the purpose 
of consistent data management, so that no WinCC engineering licenses are 
required on the OSs. Nevertheless, each time the WinCC Explorer is opened, 
a licence-free time window of two hours is enabled for WinCC configuration 
works. 

 

Step Activity Screenshot 

1.  Open the OS project on the Master OS.  

2.  Open the "Redundancy" editor. 

Check the name of the Master OS in the 
"Server" field. 

Activate the "Default Master" option. 

Also check whether the name of the 
Standby OS is entered correctly under 
"Redundant partner server:". 

Check whether your desired check boxes 
are activated under "Optional Settings". 

 

If you operate the RS 232 redundancy 
cable on a port which is not the COM1 
port, you must set the corresponding port 
under "Connection to redundant partner 
via serial interface:". 

 

Click the "OK" button to confirm the 
settings. 
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Step Activity Screenshot 

3.  Open the "Time Synchronization" editor. 

 

Check or activate the check box 
"Synchronization via System Bus (Master, 
Slave)". 

Check or select "CP1623(ISO)" and the 
option button "Master" under "Access point 
1". 

 

Click the "OK" button to confirm the 
settings. 

 

4.  If you have carried out project changes in 
WinCC Explorer, close the OS project and 
reopen it for the settings to take effect. 

 

5.  Repeat steps 1 to 4 on the Standby OS 
with the following modifications for step 2 
(redundancy): 

 The check box "Default Master" must 
be deactivated. 

 Check whether the name of the 
Master OS is entered correctly under 
"Redundant partner server:" and 
change it if required. 
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5.3.3 Activating the runtime 

Activate the OS project, first on the Master OS and then on the Standby OS. It is 
recommended to wait before activating the second runtime until the boot process 
of the first one has completed. 

With regard to redundancy, the online synchronization is immediately active. 
As opposed to this, the mutual synchronization of archives starts 10 minutes later. 
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6 ES/Master OS and Standby OS 

6.1 Configuration description 

In this configuration with two redundant OS single stations, one of the two stations 
also serves as a simultaneous ES, which saves the need for a separate third 
station. 

The following two criteria must be observed, which is why we generally recommend 
creating a configuration with a separate ES (see chapter 5 "ES, Master OS and 
Standby OS"): 

Comparatively low saving potential 

The saving potential has been reduced since PCS 7 V8.0 because the OS runtime 
license is not included with the ES license any longer. Therefore, the savings are 
limited to one computer (hardware and Windows license). 

 

Particularities when configuring 

The configuration differs from that of the PCS 7 Engineering Standard and 
represents a kind of workaround. 

The "WinCC Application" and "WinCC Standby Application", which are the 
standard means of PCS 7, cannot be used, as it is not possible to download 
changes during operation. The mechanisms, that both systems must be in runtime, 
and that the runtime on the ES must be stopped for the download to proceed, block 
each other off. 

For this reason, we only configure an OS application, open it on both stations and 
configure their mutual redundancy locally in WinCC. To be able to download to 
the OS Single Station, the runtime on the ES and the OS must be first closed. 

 

NOTICE This configuration has been tested with a PCS 7 basic installation including 
the Web Option. No statement can be made regarding the functionality with 
additional optional packages. 

 

NOTE The jumping keys in the asset faceplates to HW configuration and to PDM work 
as follows: 

– Up to PDM V8.1: Only on ES 

– From PDM V8.2: ON ES and OS standby 
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Hardware assembly 

ES/OS Master OS Standby

COM-Cable

Terminal bus

Plant bus

AS

Redundancy

 

 

PCS 7 configuration 
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Limitations/particularities 

Due to the untypical configuration of PCS 7 with only one OS, there are differences 
in system behavior that must be observed: 

 The first activated OS takes over the master role. 

 For an entire download to be performed, the runtime must be deactivated and 
the OS project closed in both computers. During this time, operator actions and 
archiving are both not possible. 

 To download changes, the runtime on the ES must be stopped when compiling 
the OS. These can be then re-activated to test the modified OS functions. For 
the downloading process, the runtime must be terminated and the OS Project 
closed. 
During this time, the operator is restricted from taking any actions on the ES 
computer. 

 

NOTICE Depending on the changes performed, if the runtime remains active during OS 
compilation, it can happen that a subsequent downloading of changes is not 
performed completely, which will cause errors. If this happens, only an entire 
download is possible. 

 

 When the runtime is active on the ES computer, the runtime archives are 
stored in the multiproject path. They are incorporated in the ZIP file when 
archiving and therefore cause an increased demand on memory resources 
as well as longer archiving times. 
Workaround: 

– Deactivate the runtime on the ES computer 

– Reset the archives in the OS project on the ES computer and close the 
entire PCS 7 project 

After archiving and after re-activating the runtime, the archives are 
synchronized again. However, it must be noted that more time is needed for 
synchronization. 
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6.2 Required hardware and software licensing 

Hardware 

The following hardware is recommended for this configuration and can be ordered 
via the Siemens mall. This ensures that the appropriate amount of operating 
systems of your choice and SIMATIC PCS 7 system software are pre-installed 
on the PC stations. 

 

Station Product label Operating 
system 

System bus transition 

ES/OS SIMATIC PCS 7 ES/OS IPC847D 
BCE 

Windows 7 RJ45 
network card 

SIMATIC PCS 7 ES/OS IPC847D 
IE 

Windows 7 CP 1623 

OS Single Station  SIMATIC PCS 7 ES/OS IPC847D 
BCE 

Windows 7 RJ45 
network card 

SIMATIC PCS 7 ES/OS IPC847D 
IE 

Windows 7 CP 1623 

 

Software Licensing 

The following section lists the software/license packages required for this 
configuration selection. 

 

Component Software/licence package 

ES  SIMATIC PCS 7 AS/OS Engineering Software V8.2  
(PO unlimited) 

 SIMATIC PCS 7 AS Runtime License 
 

OS Single Station Redundant  SIMATIC PCS 7 OS Software Single Station Redundancy 
V8.2 (Single License for 2 installations) 

 2x SIMATIC PCS 7 OS Runtime License 
(max. 2000 PO) 
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6.3 Step-by-Step configuration 

Note The following instructions have been created based on Windows 7 and 
PCS 7 V8.2. 

CP1623 are used as an example for the system bus transition. The time 
synchronization is additionally activated. 

The PC stations used in the test setup are called: 

 ES/Master OS: ESV81 

 Standby OS:  SV 

6.3.1 ES configuration 

Creating the multiproject 

As a basis for the following instructions, all PC stations must be physically 
connected according to the chart in chapter 6.1. A multiproject must be also 
created on the ES, where the hardware and software of the AS are already 
configured. 

Start from the following CPU and CP settings. 

 

AS settings for time synchronization 

The analyzability of the process data requires that all the components of the 
process control system work with an identical clock time in order to be able to 
assign messages in the correct temporal order. 

The following section describes a way in which the initially activated OS single 
station predetermines the master time. 

 

Note More time synchronization possibilities are described in detail in the following 
manuals: 

 SIMATIC Process Control System PCS 7 Operator Station (V8.2)  

 SIMATIC Process Control System PCS 7 Time synchronization (V8.2) 

https://support.industry.siemens.com/cs/ww/en/view/109485970
https://support.industry.siemens.com/cs/ww/en/view/109485963
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Step Activity Screenshot 

1.  Open the HW Config for the AS. 

Select the CPU and choose "Object 
properties..." in the shortcut menu. 

 

2.  Switch to the "Diagnostics/Clock" tab. 

In the "Clock" section, set "Synchronization 
Type - As slave". 

Click the "OK" button to confirm this 
setting. 

 



6 ES/Master OS and Standby OS 

6.3 Step-by-Step configuration 
 

PCS 7 Minimal Configuration 
Entry ID: 24023824,    V6.0,    06/2016   81 
 


 S

ie
m

e
n

s
 A

G
 2

0
1

6
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

Step Activity Screenshot 

3.  Open the shortcut menu of the CP and 
select "Object properties…". 

 

4.  Switch to the "Time synchronization" tab. 

Activate the check box "Accept time of 
day on CP and forward". 

Click the "OK" button to confirm the 
selection. 

 

5.  Save the configuration via the command 
"Station > Save and compile..." 

Close the HW Config 
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Setting up the ES PC station 

In order to run the OS project on the ES, a PC station is created for the ES with 
the WinCC application. 

 

Step Activity Screenshot 

1.  Open the shortcut menu of the project in 
the component view and add a new PC 
station via "Insert New Object > SIMATIC 
PC station". 

Change the name of the PC station so that 
it matches the name of the local computer 
on the network. 

 

2.  Open the HW Config of the ES PC station 
via the shortcut menu. 

 

3.  From the object catalog ("View > Catalog") 
insert a "WinCC application" and a network 
card of the type "CP1623". 
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Step Activity Screenshot 

4.  Select the system bus from "Subnet" or 
set this by pressing the "New..." button. 

Assign the corresponding MAC address 
to the CP1623. 

Deactivate the check box "IP protocol 
is being used". 

Click the "OK" button to confirm the 
settings. 

 

5.  Open the shortcut menu of the CP1623 
and select "Object properties…". 

 

6.  Go to the "Options" tab and select the 
check box "Time of day". 

Click the "OK" button to confirm the 
selection. 

 

7.  Save and compile the configuration via 
the menu command: "Station > Save and 
Compile…". 

Close the HW Config 

 

8.  

 

Delete the OS of the PC station of the ES 
in SIMATIC Manager, as it is not needed 
in our example. 
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Setting up the Standby OS PC station 

Step Activity Screenshot 

1.  Open the shortcut menu of the project in 
the component view and add a new PC 
station via "Insert New Object > SIMATIC 
PC station". 

 

2.  Open the HW Config of the Standby OS 
PC station via the shortcut menu. 

 

3.  From the object catalog (View > Catalog) 
insert a "WinCC application (no WinCC 
Application Stby!)" and a network card 
of the type "CP1623". 
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Step Activity Screenshot 

4.  Select the system bus from "Subnet" or 
set this by pressing the "New..." button. 

Assign the corresponding MAC address 
to the CP1623. 

Deactivate the check box "IP protocol is 
being used". 

Click the "OK" button to confirm the 
settings. 

 

5.  Open the shortcut menu of the CP1623 
and select "Object properties…". 

 

6.  Go to the "Options" tab and select the 
check box "Time of day". 

Click the "OK" button to confirm the 
setting. 

 

7.  Save and compile via the command: 
"Station > Save and Compile…". 

Close the HW Config 
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Step Activity Screenshot 

8.  In SIMATIC Manager, open the properties 
dialog of the Standby OS. 

Switch to the "Target OS and Standby OS 
Computer" tab. 

Activate the check box "Create/update 
archive tags" and deactivate the check box 
"Transfer to external archive server". 

Click on the "Search..." button. 

 

9.  Navigate via the drop-down list to the 
shared project folder of the Standby OS 
(see 5.3.1 Preparatory activities). 

Click the "Save" button. 

 

10.  In the text box, reselect the whole project 
path "Path to Target OS Computer". 

Click the "OK" button to confirm this. 

 

11.  Confirm the information dialog by clicking 
the "Yes" button. 
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Configuring the PC stations 

The function "Configure PC station" transfers project configurations to one or more 
target stations. First configure the local Station Configuration Editor of the ES and 
then all the other PC stations connected to the system bus. 

 

Step Activity Screenshot 

1.  Execute the Station Configuration Editor of 
the ES. To do this, select the PC station of 
the ES and in the shortcut menu choose: 
"PLC > Configure...". 

 

2.  Select the PC to be configured from 
"Accessible computers:". 

 

Note 

If you have chosen the option "Identical PC 
name to PC station name" via "Object 
properties", the target PC to be configured 
appears directly in the component 
configurator. 

 

Use the "Show" button to display the 
current configuration of the PC station. 

Click on the "Configure…" button. 
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Step Activity Screenshot 

3.  In the window that appears you will see 
how the PC station is configured. 

Click the "OK" button to confirm this 
setting. 

 

4.  Confirm the information dialog by clicking 
on "OK". 

 

5.  In the bottom window you will then see 
the message: 
"Transfer completed successfully". 

Close the configuration dialog. 
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Step Activity Screenshot 

6.  Configure the Station Configuration 
Editor of the Standby OS as shown in 
steps 1 to 5. 

 

 

Configuring and loading AS-OS communication 

In the following section, the connections between the PC stations and the AS are 
configured in NetPro and loaded in the individual stations. 

Note In case of a granular station configuration, the subnets of the individual sub-
projects must be first merged. 

 

Step Activity Screenshot 

1.  Open NetPro. 

Select the WinCC application of the ES 
and open the shortcut menu. 

Select "Insert New Connection". 

 

2.  Select the CPU of the AS in the 
"Connection Partner" window. 

Make sure that an "S7 connection" 
is selected under "Connection". 
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Step Activity Screenshot 

3.  Under "Connection identification" in the 
"General" tab, change the "Local ID:" 
to a descriptive name, such as AS60. 

Click the "OK" button to confirm the 
settings. 

 

4.  Also create a connection between the 
Standby OS and the AS by repeating 
steps 1 to 3. 

When doing this it is important that the 
connection has the same name as the 
connection of the ES to the AS. 

When ready, save and compile the 
configuration via the menu command: 
"Network > Save and Compile…". 

 

Select the option button "Compile and 
check everything" and confirm your 
selection with the "OK" button. 

 

5.  Select the ES and download the 
connections via the shortcut menu: 
"Download to current project > Selected 
Stations". 

Download the Standby OS and the AS in 
the same way. 

Then close NetPro. 

 

 

Compiling and loading the user program 

Compile the S7 program and download it to the AS. 

 

Compiling the OS project 

Compile the OS project of the Standby OS in SIMATIC Manager. 

Make sure to make the correct OS assignment to the server in the plant view. 
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6.3.2 OS configuration 

OS configuration on the engineering station 

On the ES, a conversion must be still done from a multi-user to a single-user 
system, and the settings for the redundancy and time synchronization must be still 
adjusted. 

 

Note In this particular configuration, it is necessary to complete the redundancy 
settings in WinCC Explorer of the Standby OS after the entire download 
completes. 

 

Step Activity Screenshot 

1.  Open the OS project of the Standby OS 
in the ES. 

Select the OS project in the open WinCC 
Explorer and select "Properties" in the 
shortcut menu. 
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Step Activity Screenshot 

2.  Under "Type:" in the "General" tab, select 
the project "Single-User Project" from the 
drop-drop-down list. 

 

Confirm your settings and the displayed 
message by clicking the "OK" button. 

 

3.  Activate the OS project option "Allow 
activation on ES" from the "Options" tab. 
This setting allows the runtime to be 
activated in the ES. 

Then click on the "OK" button. 
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Step Activity Screenshot 

4.  Prevent deleting the startup list by clicking 
the "No" button. 

Confirm the displayed message by clicking 
on "OK". 

 

5.  Open the "Redundancy" editor. 

 

Activate the "Activate Redundancy" option. 

Select the option "Default Master". 

Adjust the redundancy properties in 
"Optional Settings" according to your 
requirements. 

If you do not want to operate the RS 232 
redundancy cable on the COM1 interface, 
you must adjust this setting later yourself 
on the Standby OS (see section "OS 
configuration on the Operator Station"). 

 

6.  To complete the redundancy settings for 
the ES, the partner server must be still 
selected. 

Click the "Search ..." button and select the 
Standby OS as a redundant partner from 
the network. 

Click the "OK" button to confirm the 
settings. 
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Step Activity Screenshot 

Double check all your options before you 
confirm the redundancy settings with the 
"OK" button. 

 

Confirm the displayed note by clicking 
the "OK" button. 

 

7.  Open the "Time Synchronization" editor. 

Activate the check box "Synchronization 
via System Bus (Master, Slave)". 

Select "CP1623(ISO)" under "Access point 
1" and activate the check box "Master". 

Click the "OK" button to confirm the 
settings. 

 

Note 

If the ES does not have a CP1623, then 
activate the option "Display symbolic name 
of the access point" and select the 
appropriate access point. 

 

8.  Close the OS project.  
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Downloading the OS project to the Standby OS 

Once the redundancy and time synchronization are configured on the ES and 
the OS project is closed again, download the OS project on the Standby OS. 

 

Step Activity Screenshot 

1.  In SIMATIC Manager, select the Standby 
OS and choose the following in the context 
menu: "PLC > Download". 

 

2.  For the first OS project download, an entire 
download is required. 

Start the download by clicking the "OK" 
button. 
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Step Activity Screenshot 

3.  After a successful download, the OS 
project is located in the specified folder 
on the Standby OS. 

Click the "OK" button to confirm the 
corresponding message. 
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OS configuration on the Standby OS 

In this particular configuration, it is necessary to complete the redundancy settings 
after the download completes. 

If, as opposed to the operator station, the engineering station has no CP1623 or 
if the RS 232 redundancy cable is not connected to the COM1 port, the following 
step instructions must be carried out. Generally we advise you to check the project 
settings after the project has been downloaded to the target system. 

 

Note Normally, all the engineering work will be carried out on the ES for the purpose 
of consistent data management, so that no WinCC engineering licenses are 
required on the OS. Nevertheless, each time the WinCC Explorer is opened, 
a licence-free time window of two hours is enabled for WinCC configuration 
works. 

 

Step Activity Screenshot 

1.  Open the OS project on the OS standby 
under the shared project folder. 

 

2.  Open the "Redundancy" editor from the 
shortcut menu. 

 

Click the "Search ..." button and select 
the ES computer as a redundant partner. 
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Step Activity Screenshot 

Deactivate the check box "Default Master". 

Check whether your desired check boxes 
are activated under "Optional Settings". 

 

Click the "OK" button to confirm the 
settings. 

 

Confirm the displayed note by clicking 
the "OK" button. 

 

3.  Open the editor "Time Synchronization" 
from the shortcut menu. 

 

Check or activate the check box 
"Synchronization via System Bus 
(Master, Slave)". 

Check or select "CP1623(ISO)" and the 
option button "Master" under "Access 
point 1". 

 

Always click the "OK" button to confirm the 
settings. 
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Step Activity Screenshot 

4.  If you have carried out project changes in 
WinCC Explorer, close the OS project and 
reopen it for the settings to take effect. 

 

 

6.3.3 Activating the runtime 

Activate the OS project, first on the ES and also on the Standby OS. It is 
recommended to wait before activating the second runtime until the boot process 
of the first one has completed. 

With regard to redundancy, the online synchronization is immediately active. 
As opposed to this, the mutual synchronization of archives only starts 10 minutes 
later. 

 

6.3.4 Particularities when loading the OS project changes 

Loading changes 

To download changes, the runtime on the ES must be stopped when compiling 
the OS. These can be then re-activated to test the modified OS functions. 

 

NOTICE Depending on the changes performed, if the runtime remains active during OS 
compilation, it can happen that a subsequent downloading of changes is not 
performed completely, which will cause errors. If this happens, only an entire 
download is possible. 

 

For the downloading process, the runtime must be terminated and the OS Project 
closed. 
This results in the operator being restricted from taking any actions on the ES 
computer. 

 

Complete download 

For a complete download the following must be always observed: 

1. The runtime must be deactivated on both PC stations and the OS project must 
be closed. 

2. Before enabling the runtime on the Standby OS again, the redundancy settings 
must be set again. 
Do this by repeating the steps in the table on page 97. 
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7 Expansion with the PCS 7 OS Web Option 

Positioning 

In order to control automated processes via the Internet/Intranet, SIMATIC PCS 7 
provides operating and monitoring options: the so-called "Web Options". 

This chapter describes the configuration of the Web Option on one ES/OS single-
user system. The instructions can also be used as an expansion for the following 
minimal configurations: 

 ES/OS single-user system (Chapter 3) 

 ES/Master OS and Standby OS (Chapter 6) 

 

Note To expand the redundant single-user system configuration with the Web Option, 
the ES/OS station in the following example has been configured as a Web 
Server. The partner OS could also be used the same way as a Web Server. 
Nothing changes in the functionality for the Web clients. 

The redundancy of the operator stations is not available for Web clients. If the 
OS with the Web Server option is in STOP, even the Web clients have no 
connection to the process. 

 

Function 

All relevant pictures and scripts are stored on the Web Server to enable them to be 
displayed or run through a Web client. 

The Web client accesses the system data provided by the Web Server via 
a TCP/IP connection. The user interface corresponds to the appearance of 
a standard OS client with overview, work and key area. 

The following functions are some of the ones available via Web: 

 Operator control and monitoring functions, which are also used on an OS client 

 Message lists that are called up in a user-dependent manner, just like on an 
OS client. Messages can be acknowledged in a user-dependent manner. 

 Displaying the picture hierarchy according to the plant hierarchy 

 Group display function including the "loop-in-alarm" function 

 Extended status display 

 

 

Note For further information about the PCS 7 Web Options, see the following manual: 
"SIMATIC Process Control System PCS 7 Web Option for OS (V8.2)" 

https://support.industry.siemens.com/cs/ww/en/view/109485959
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7.1 Web configurations 

In our example, the configuration of the Web Option represents an expansion of 
the hardware and software configurations mentioned in chapter 3, "ES/OS single-
user system" and chapter 6 "ES/Master OS and Standby OS". 

 

ES/OS single-user system with OS Web Server option 

To operate and monitor the system process, the OS Web clients draw their project 
data from the single-user system with the OS Web Server option via Internet/ 
Intranet by means of Internet Explorer. 

ES/OS + OS Web Server

Plant bus

Intranet/Internet

Web Clients

AS
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ES/Master OS with OS Web Server option 

To operate and monitor the system process, the OS Web clients draw their data 
from the single-user system with the OS Web Server option via Internet/Intranet 
by means of Internet Explorer. 

In addition, the system process is set as redundant to offer a widest possible 
protection against failure of system operation. 

 

NOTICE The redundancy of the operator stations is not available for Web clients. 
If the OS with the Web Server option is in STOP, the Web clients have no 
process connection. 

 

ES/OS + OS Web Server

Plant bus

Intranet/Internet

Web Clients

OS Single

Station

COM-Cable

AS

Redundancy
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7.2 Web-specific hardware and software requirements 

Single-user system with Web Server option 

Characteristic Requirement 

Operating system  Windows 7 Ultimate/Enterprise SP1 (32 bit) 

 Windows Server 2008 R2 SP1 Standard Edition 
(64 bit) 

 

For further information, see the document  

"SIMATIC Process Control System PCS 7 
Readme V8.2 (online)". 

Hardware  SIMATIC PCS 7 ES/OS IPC847D BCE 

 SIMATIC PCS 7 ES/OS IPC847D IE 

For further information, see the document  

"SIMATIC Process Control System PCS 7 
Readme V8.2 (online)". 

Software  Internet Explorer 

 Internet Information Server (IIS) 

Other Faster access (>= 64 kbit/s) to the Web client via 
internet/intranet or TCP/IP connection 

 

https://support.industry.siemens.com/cs/ww/en/view/109478781
https://support.industry.siemens.com/cs/ww/en/view/109478781
https://support.industry.siemens.com/cs/ww/en/view/109478781
https://support.industry.siemens.com/cs/ww/en/view/109478781
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Web client 

Characteristic Requirement 

Operating systems  Windows 7 Ultimate/Enterprise SP1 (32 bit) 

 Windows 7 Ultimate/Enterprise SP1 (64 bit) 

 Windows Server 2008 R2 SP1 Standard Edition 
(64 bit) 

 

For further information, see the document 

"SIMATIC Process Control System PCS 7 
Readme V8.2 (online)“. 

Minimum hardware 
requirements 

No PDAs, tablet PCs etc. 

Software Internet Explorer 

Other Faster access (>= 64 kbit/s) to the Web client via 
internet/intranet or TCP/IP connection 

 

Note The Internet Explorer version must be selected according to the PCS 7 version. 
For further information, see the following FAQ: 
https://support.industry.siemens.com/cs/ww/en/view/2334224 

 

7.3 Maximum amount of Web client connections 

The following number of concurrent Web client connections have been tested and 
thus released: 

Operating system on the stand-alone system 
with Web Server option 

Maximum number of concurrent 
Web connections 

Windows 7 3 

Windows Server 2008 3 

 

https://support.industry.siemens.com/cs/ww/en/view/109478781
https://support.industry.siemens.com/cs/ww/en/view/109478781
https://support.industry.siemens.com/cs/ww/en/view/2334224
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7.4 Configuring the OS Web Server 

Configuration steps on the ES 

 Publishing pictures via Web View Publisher 

 Configuring user rights, start screen and language of the website in the User 
Administrator 

 Downloading and compiling the Web Server 

 

Publishing OS data 

The Web Publisher enables pictures and scripts, which should later run on the 
Web clients, to be published on the OS Web Server. The following actions are 
performed: 

 Project data is compressed and saved 

 Picture windows are converted into Internet-enabled ActiveX components 

 Scripts are converted so that they run on the Web 

 

Requirements 

Before publishing the Web Server data, the following requirements must be met: 

 The hardware and software requirements mentioned in chapter 7.2 have been 
met. 

 The software package "PCS 7 Web Server" is installed on the ES/OS single-
user system. 

 The PCS 7 Project is available and fully configured. 

 "OS compiling" has been completed. 

 The scripts that are accessed by the Web clients are present. 

 Process pictures contain no double underscore (e.g. yy__xx.pdl). 

 Tag names in plain text (quotation marks) within C scripts contain no spaces. 

 

Note In a single-user system, only one publishing process is needed for the publishing 
of local data on the Web Server. 

For information regarding the subject "supported script standard functions" 
see the chapter "Web-enabled Functions for PCS 7 OS Web Option" in the 
manual: "SIMATIC PCS 7 Web Option for OS (V8.2)". 

 

https://support.industry.siemens.com/cs/ww/en/view/109485959
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7.4.1 Publishing project data 

Step Action Remark 

1.  Open the OS project of the OS Web Server 
in WinCC Explorer. 

Using the shortcut menu of the "Web 
Navigator" editor, select the command 
"Web View Publisher". 

The dialog box "WinCC Web Publishing 
Wizard - Introduction" opens. 

Click on the "Next" button. 

 

2.  This opens the dialog box "WinCC Web 
Publishing Wizard – Select files and 
folders". 

Deactivate the check box "Server Prefix" 
because you want to publish local data. 

Accept the default destination and source 
path. If you really want to change the 
respective path, click on the button behind 
the grayed entry fields. Navigate to the 
desired target or source folder. 

Click on the "Next" button. 

 

3.  The dialog box "WinCC Web Publishing 
Wizard - Select pictures" opens. 

Select all pictures you wish to publish. 
We recommend to publish all standard 
pictures. 

Use the ">>", "<<", ">" and "<" buttons 
to select the pictures. 

Click on the "Next" button. 

 

4.  The dialog box "WinCC Web Publishing 
Wizard - Select functions" opens. 

Select all functions you wish to publish. In 
the pictures, only the scripts that you 
selected during the publication process are 
available. Therefore, select all the needed 
functions at every publication process. 

Use the ">>", "<<", ">" and "<" buttons to 
select the functions. 

Click on the "Next" button. 
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Step Action Remark 

5.  The dialog box "WinCC Web Publishing 
Wizard - Referenced graphics" opens. 

Select all the graphics you wish to publish. 
We recommend to publish all standard 
graphics. 

Use the ">>", "<<", ">" and "<" buttons to 
select the graphics. 

Click on the "Next" button. 

 

6.  The dialog box "WinCC Web Publishing 
Wizard - Finish" opens. 

Click "Finish". 

 

 

7.  Pictures and functions that contain faulty 
scripts are identified from a red cross. 

Double-click on each faulty picture to open 
the picture in the editor "PdlPad" and to 
correct it. 

Once the publishing process is complete, 
click the "OK" button to confirm the 
message. 
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Step Action Remark 

8.  The transferred images are listed in the 
dialog box "WinCC Web Publishing Wizard 
– Finish". 

Click "Finish". 

 

9.  The published pictures are displayed in 
the data window of the Web Navigator. 
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7.4.2 Setting up user rights, website start screen and language 

Restriction of access 

You can control the connections of the Web client to the OS Web Server by 
defining user rights. User rights are assigned in the editor "User Administrator". 
User rights are the same as those of the standard clients. 

 

Settings in the editor "User Administrator" 

Step Action Remark 

1.  Open the editor "User Administrator" in the 
WinCC Explorer of the currently open OS 
project. 

Add the new users and/or new user 
groups to which you want to assign 
appropriate permissions. 

Also activate the option button "Web 
Navigator" for the user/s or user group/s 
and enter the website in the corresponding 
input fields "Start Screen" and "Language".  

2.  Use the "..." button to select the start 
screen from the published graphics. 

"…\OS Web Server\<wincc-projectrelease-
Name>\Web Navigator\pictures" 

Select the graphic "@screen.pd_" as start 
screen. 

Click the "OK" button to confirm your 
selection. 

You can also specify a language for the 
control and monitoring interface of the 
Web clients. To do this, you must also 
click the corresponding button "...". 

Click the "OK" button to confirm your 
selection. 

 

3.  Close the User Administration Editor.  

 



7 Expansion with the PCS 7 OS Web Option 

7.4 Configuring the OS Web Server 
 

PCS 7 Minimal Configuration 
Entry ID: 24023824,    V6.0,    06/2016   110 
 


 S

ie
m

e
n

s
 A

G
 2

0
1

6
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

7.4.3 Configuring with the Web Configurator 

Web Configurator tasks 

The Web Configurator enables you to configure and manage the Internet 
Information Service (IIS) and therefore the website of the OS Web Server. 
The setting up is performed on the Web Server after you have downloaded the 
project to the Web Server. Setup and configuration are necessary to set up an 
operating station (OS) as an OS Web Server and to make it accessible for the 
Web clients via the intranet/internet. 

The Web Configurator enables you to adjust the necessary firewall settings, 
if a firewall is enabled. 

 

Requirements of the single-user system 

 The PCS 7 Web Server software is installed on the single-user system 

 The OS project has been downloaded to the single-user system 

 All settings have been entered in the OS 

 Pictures, functions and graphics are published 

 User rights have been granted/applied 

 

Note For further information about the default Web page, see the chapter 
"Configuration on the OS Web Server" in the manual: 
"SIMATIC PCS 7 Web Option for OS (V8.2)". 

 

https://support.industry.siemens.com/cs/ww/en/view/109485959
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Settings in the editor "Web Navigator" 

Step Action Remark 

1.  Open the OS project in WinCC Explorer on 
the OS Web Server. 

Using the shortcut menu of the "Web 
Navigator" editor, select the command 
"Web Configurator". 

The dialog box "WinCC Web Configurator" 
opens. 

Click on the "Next" button. 

 

2.  In the next window, select "Create a new 
standard Web site (stand-alone)". 

Click on the "Next" button. 

 

3.  Assign a name to your website in the 
"Name of the Web site" text box. 

Also assign the IP address and connection 
port of the computer using the text boxes 
"Port" and "IP address". 

In the "Default Web-Page" text box, select 
"MainControl" from the drop-down list. 

Also enter a time interval in the text box 
"Reconnect Interval". 

Activate the check box "Start the web-site 
after being configured". 

Click on the "Next" button. 

If your Windows firewall is not activated, 
skip to step "7". 

 

4.  Click on the "Windows Firewall" button (the 
button is only visible if the firewall is 
activated). 
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Step Action Remark 

5.  Click the button "Advanced Settings" 
in the "Windows Firewall" dialog box. 

 

6.  Check whether the inbound rule "World 
Wide Web Services (HTTP Traffic-In) is 
activated. If this feature is deactivated, 
select it and choose the command "Enable" 
in the shortcut menu. 

 

7.  Click "Finish". 

 

8.  Click the "OK" button. 

Then close WinCC Explorer and restart 
your computer to apply the settings. 
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7.4.4 Downloading and compiling the Web Server 

Downloading the Web Server 

Since the OS Web Server function is on a single-user system (ES/OS/Web 
Server), it is not necessary to perform a download or changes download of project 
data. Thanks to the "Compile OS", the necessary data are already available locally. 

 

Compiling 

The "Compile Changes" function can be performed in single-user systems without 
having to interrupt the process mode of the Web Server. 

 

Note For further information about the default Web page, see the chapter "Configuring 
the OS Web Server on an ES" in the manual:  

"SIMATIC PCS 7 Web Option for OS (V8.2)". 

 

https://support.industry.siemens.com/cs/ww/en/view/109485959
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7.5 Settings for the Web client 

Settings for the Web content zone "Internet" or "Local Intranet" 

In Internet Explorer, you must adjust/check the settings for the Web content zone, 
so that later you'll be able to install the plug-ins for the Web client from the OS Web 
server. 

Step Action Remark 

1.  Open Internet Explorer. 

Select the menu command: 
"Tools > Internet Options". 

 

2.  Click on the "Security" tab. 

Select the Web content zone in which the 
Web server resides ("Internet" or "Local 
intranet"). 

Click on the "Custom Level" button. 
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Step Action Remark 

3.  Activate the option buttons under "Run 
ActiveX controls that are safe for scripting" 
and "Download signed ActiveX controls". 

 

4.  Click on each of the "OK" button for the 
dialog boxes "Security Settings" and 
"Internet Options" to close them. 
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Settings for the Web content zone "Trusted sites" 

Step Action Remark 

1.  Open Internet Explorer. 

Select the menu command: "Tools > 
Internet Options" 

 

2.  Click on the "Security" tab. 

Select the Web content zone "Trusted 
sites". 

Click the "Sites" button to open the dialog 
box. 

 

3.  In the text box "Add this website to the 
zone", insert the address of the OS Web 
server  
(7.4.3 Configuring with the Web 
Configurator > Settings in the editor "Web 
Navigator") 

e.g. *://172.61.0.1 or 

http://*.microsoft.com 

Also deactivate the check box "Require 
server verification (https:) for all sites in this 
zone". 

Click on the "Add" and "Close" buttons. 

 

http://*.microsoft.com/
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Step Action Remark 

4.  Select the Web content zone "Trusted 
sites". 

Click on the "Default level" button and then 
on the "Custom level" button. 

 

5.  In the "Security Settings" dialog box, enable 
the option button under "Initialize and script 
ActiveX controls not marked as safe for 
scripting". 

 

6.  Click on each of the "OK" button for the 
dialog boxes "Security Settings" and 
"Internet Options" to close them. 

 

 

You have now managed to create the conditions required for a connection from 
of a Web client to a Web server. 
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7.6 Installing the Web client plug-ins 

Installation ways 

During the installation of plug-ins for Internet Explorer, you can choose between 
two installation ways: 

 Remote Installation - Installation via the Intranet/Internet from the Web server 

 Local Installation - Installation via the Windows installer package of the Web 
client 

In this application example, we consider the "remote installation". 

 

Requirements 

 The OS Web server is in runtime. 

 The software package "PCS 7 Web Client" is installed on the PC. 

 The Web client has access to the Web server. 

 You know the Web server's address. 

 You know the domain name, username and password. 

 The user permissions apply for the PCS 7 Web Options. 

 The logon session on the PC has the rights of a primary user. 

 

Installation 

Step Action Remark 

1.  Open Internet Explorer. 

Enter the web server address 
(http://<server name or IP>) in the 
"Address" text box. 

 

2.  In the "Enter Network Password" dialog 
box, enter the credentials that were set in 
the "User Administrator" editor on the Web 
server. 
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Step Action Remark 

3.  When you first connect, the "Security 
Warning" dialog box will open. 

Proceed by clicking on the "Install" button. 

 

4.  All the available plug-ins for the Web client 
will now be displayed in the Internet 
Explorer window. 

To install the plug-in, click on the arrow in 
front of the version number in the "Install" 
column.  

The following plug-ins are installed to 
ensure a minimum of process control: 

 WinCC Basic Process Control 

 WinCC Advanced Process Control 

 PCS 7 Basic Faceplates 

 PCS 7 Advanced Faceplates 

During installation, always follow the shown 
sequence. 

 

5.  The installation of the Web client is 
complete. 

Close Internet Explorer and reopen it in 
order to register for the process control. 

The process pictures can be called up once 
the Web client has established a connection 
to the Web server. 

 

 

Note Further information about the topics "Installing a Web client", "Process control 
on the Web client" and "Settings" in the manual: 
"SIMATIC PCS 7 Web Option for OS (V8.2)" by reading the chapter: 
"Installations and Settings for the Web Client" 

https://support.industry.siemens.com/cs/ww/en/view/109485959
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8 History 
 

Version Date Change  

V1.0 10/2006 First edition V6.1 SP1 

V1.1 11/2006 Revised V6.1 SP1 

V1.2 05/2009 Revised V6.1 SP1 

V2.1 09/2008 First edition V7.0 SP1 

V2.2 12/2008 Correction of table 6–2 

V2.3 05/2009 Revision V7.0 SP1 

V3.0 05/2009 First edition V7.1 

V3.1 05/2009 Revision V7.1 

V3.2 11/2009 Extension of the document for V7.1 to include the PCS 7 
Web Option (tested for PCS 7 V7.1 and V7.0 SP2) 

V2.4 12/2010 Note added: 

The configuration described in chapter 6, "ES/Master OS 
and Standby OS" only works in PCS 7 V7.0 SP3 if it has 
WinCC V6.2 SP3 HF8 or higher. 

V3.3 09/2011 Note added: 

The configuration described in chapter 6, "ES/ Master OS 
and Standby OS" only works in PCS 7 V7.1 SP2 and SP3 
if it has WinCC V7.0 SP2 HF5 or higher. 

V4.0 10/2012 First edition PCS 7 V8.0 Upd1 

V4.1 11/2012 Adaptations in the following chapters: 

 Chapter 7 "Expansion with the PCS 7 OS Web Option" 

 Chapter 7.1 "Web configurations" 

 Chapter 7.2 "Web-specific hardware and software 
requirements" 

New chapter: 

 Chapter 7.3 "Maximum amount of Web client 
connections" 

V4.2 01/2013 Introduction in chapter 6 "ES/Master OS and Standby OS" 
has been editorially revised. 

V4.3 05/2013 Test and declaration for PCS 7 V8.0 SP1 

V4.4 09/2013 License adjustments in chapter 7.1. "Web configurations" 
in Figure 7–1 "Web Option in single-user system" 

V5.0 02/2015 Test and declaration for PCS 7 V8.1 

V6.0 06/2016 Test and declaration for PCS 7 V8.2 

 


	SIMATIC PCS 7  Minimal Configuration
	Warranty and liability
	Preface
	1 Overview of the minimal configuration
	1.1 ES/OS single-user system
	1.2 ES/OS client and OS server
	1.3  ES, Master OS and Standby OS
	1.4 ES/Master OS and Standby OS

	2 General/optional system settings
	2.1 Bus connection of the PC stations
	2.2 Autostart of WinCC

	3 ES/OS single-user system
	3.1 Configuration description
	3.2  Required hardware and software licensing
	3.3 Step-by-Step configuration
	3.3.1 ES configuration
	3.3.2 OS configuration
	3.3.3  Activating the runtime
	3.3.4 Particularities when loading the OS project changes


	4 ES/OS client and OS server
	4.1 Configuration description
	4.2 Required hardware and software licensing
	4.3 Step-by-Step configuration
	4.3.1 Preparatory activities
	4.3.2 ES configuration
	4.3.3 OS configuration
	4.3.4 Activating the runtime
	4.3.5 Particularities when loading the OS project changes


	5 ES, Master OS and Standby OS
	5.1 Configuration description
	5.2 Required hardware and software licensing
	5.3 Step-by-Step configuration
	5.3.1 ES configuration
	5.3.2 OS configuration
	5.3.3 Activating the runtime


	6 ES/Master OS and Standby OS
	6.1 Configuration description
	6.2 Required hardware and software licensing
	6.3 Step-by-Step configuration
	6.3.1 ES configuration
	6.3.2  OS configuration
	6.3.3 Activating the runtime
	6.3.4 Particularities when loading the OS project changes


	7 Expansion with the PCS 7 OS Web Option
	7.1 Web configurations
	7.2 Web-specific hardware and software requirements
	7.3 Maximum amount of Web client connections
	7.4 Configuring the OS Web Server
	7.4.1 Publishing project data
	7.4.2 Setting up user rights, website start screen and language
	7.4.3 Configuring with the Web Configurator
	7.4.4 Downloading and compiling the Web Server

	7.5 Settings for the Web client
	7.6 Installing the Web client plug-ins

	8 History

