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Contacting Grass Valley

Copyright © Thomson, Inc. All rights reserved.
This product may be covered by one or more U.S. and foreign patents.

Grass Valley Web Site 
The www.grassvalley.com web site offers the following: 

Online User Documentation — Current versions of product catalogs, brochures, 
data sheets, ordering guides, planning guides, manuals, and release notes 
in .pdf format can be downloaded. 

FAQ Database — Solutions to problems and troubleshooting efforts can be 
found by searching our Frequently Asked Questions (FAQ) database.

Software Downloads — Download software updates, drivers, and patches.

International
Support Centers

France
24 x 7 +800 8080 2020 or +33 1 48 25 20 20 United States/Canada

24 x 7  +1 800 547 8949 or +1 530 478 4148

Local Support 
Centers 

(available 
during normal 

business hours)

Asia
Hong Kong, Taiwan, Korea, Macau: +852 2531 3058 Indian Subcontinent: +91 22 24933476
Southeast Asia/Malaysia: +603 7805 3884 Southeast Asia/Singapore: +65 6379 1313
China: +861 0660 159 450 Japan: +81 3 5484 6868

Australia and New Zealand: +61 1300 721 495 Central/South America: +55 11 5509 3443

Middle East: +971 4 299 64 40 Near East and Africa: +800 8080 2020 or +33 1 48 25 20 20

Europe

Belarus, Russia, Tadzikistan, Ukraine, Uzbekistan: +7 095 2580924 225 Switzerland: +41 1 487 80 02
S. Europe/Italy-Roma: +39 06 87 20 35 28 -Milan: +39 02 48 41 46 58 S. Europe/Spain: +34 91 512 03 50
Benelux/Belgium: +32 (0) 2 334 90 30 Benelux/Netherlands: +31 (0) 35 62 38 42 1 N. Europe: +45 45 96 88 70
Germany, Austria, Eastern Europe: +49 6150 104 444 UK, Ireland, Israel: +44 118 923 0499

http://www.thomsongrassvalley.com
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Version 2.2
MAY 2010

Maestro Release Notes

Purpose
This document provides software installation instructions for the 2.2 soft-
ware release of the Maestro Master Control System. This release is an 
upgrade to systems with either the Dual-Channel DVE option or no DVE 
option. 

It is assumed that the Dual-Channel DVE option has been previously 
installed on the intended system. If you do not have a DVE option installed 
and you are intending to install the Dual-Channel DVE option, see the 2.0 
version of the Maestro Release Notes (Part # 071-8506-09) or the 2.0 version 
of the Maestro Installation manual (Part # 071-8698-01), both of which can 
be found on the Grass Valley Web site.

Note If you have the Single-Channel DVE option, see the 1.7 version of the Maestro 
Release Notes (part #071-8506-08). Do NOT install this version of the 
Maestro software.

The 2.2 release provides the ability to dynamically manage Channel 
Branding content files on a specific Maestro Channel and facilitate the use 
of this dynamic content on a branding layer; for a large scale multi-user 
facility with complex media management and playout needs.

The Release Notes Addendum provides a list of software corrections and 
known limitations that are associated with this release.
MAESTRO  —  Release Notes 7
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Available Materials 

Note The Maestro software version number appears in two formats in this docu-
ment. The abbreviated format, 2.2, indicates the major version “2” and minor 
version “2” When there is a third number, it will indicate a sub version. The 
long format expresses the release number as 2.200.xxxx.xxxx with the addi-
tional digits indicating engineering information. All of the 2.2 documentation 
is on the Maestro Documentation CD-ROM.

Maestro HD Licensing
In the 2.2 version of Maestro, the software for both the HD and SD channels 
is on the same CD-ROM. You will need to enter the activation key that is 
provided with the software to access the HD channels.

Note Before installing the 2.2 and later versions of Maestro, and if you purchased 
the HD option, verify your HD licence key with Grass Valley’s Customer 
Service department. See Contacting Grass Valley on page 4 for the contact 
information for your area.

Follow these steps to unlock the HD channels:

1. Open the Maestro Configuration Editor application.

2. Open the Channel Setup table from the Navigation panel (8th Step: 
Channel Sets> Channel Setup). The Channel Setup table will then 
appear. See Figure 1.

Figure 1.  The Channel Setup Table

Table 1.  MAE-HD-SW Bill of Materials

Maestro Software Upgrade

Quantity Description Part number

1 CD-ROM, Maestro HD Software Program, 
v2.2 (1.600.3353.1054) 063825810 

1 Maestro Documentation CD-ROM 071851709
8 MAESTRO  —  Release Notes
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3. Enter the Activation key in the HD Channel Activation Key field. This 
field is located near the top of the dialog box (Figure 1 on page 8). The 
Activation Key can be found on the certificate that came with the 
system.

4. Click the Apply Key button. The HD channels will now be activated and 
the number of activated HD channels will appear in the information 
text (see Figure 1). 

Figure 2.  HD Channel Activation Key Field

The HD Channel 
Activation Key Field

Information 
Text. The 
number of acti-
vated HD chan-
nels will appear 
here. 
MAESTRO  —  Release Notes 9
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New Features 
The new features of the 2.2 version of the Maestro Master Control System 
are as follows:

Preservation of the Dolby-E Line Position
How Maestro processes audio has been modified to better support Dolby-
E switch point alignment. The Maestro software now adjusts various audio 
delay elements for each of the six supported Maestro video standards. 
These adjustments preserve the Dolby-E switch position. 

Preservation of HANC Data with Embedded Audio
The HANC data is now preserved when Maestro is embedding audio for 
output. 

Preservation of Closed Captioning for Both VBI Fields
The #283 and #284 fields under the Field 2 Number column of the VBI 
Passthrough table of the Maestro Configuration Editor application can now 
be edited. This change ensures that Closed Captioning will bypass any 
DVE or other transition processing for both VBI fields. This improvement 
is specific for the 480I standard. 

The Maestro GUI Software Control Panel 
The Maestro software GUI Control Panel now allows access to multiple 
User Systems. The software GUI Control Panel now allows delegation to 
four (4) User Systems or sub-Systems, each system will support up to 48-
channels. 

Note This ability to control multiple user systems is ONLY applicable to the 
Maestro GUI Control panels.

Additions to the Maestro Automation Interface and Protocol
The Maestro Automation Interface and Protocol has been expanded to 
allow media identification of Channel Branding Content with Still Images, 
Animation Sequences, Text Crawl and other text displays. 

The Maestro Automation Interface and Protocol now includes the fol-
lowing commands that are listed in Table 2.  
10 MAESTRO  —  Release Notes
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See the 2.2 version of the Maestro Automation Interface Protocol Technical Ref-
erence Manual (part # 071847208) for more information. 

The Maestro Content Manager Service 
The Maestro Content Manager Service allows transfer and management of 
Channel Branding Content on individual channel stores via automation 
control and FTP protocols.

The Exclusion of Internal Content for a Background Button
Internal content is now excluded from the list of sources that are available 
for default assignment in the Background Buttons table of the Maestro 
Configuration Editor for the following reasons:

• Internal content is an invalid source and cannot be assigned to a Back-
ground bus.

• The default assignment will fail on Keyers and Audio Mixers if the con-
figured Content Definition file does not exist on the Frame Processor’s 
hard disk drive. 

If a failure happens on a “Fixed Assignment” button, the failure cannot be 
resolved later through a subsequent re-assignment. This failure will result 
in a Keyer or Audio Mixer (the one that is associated with the failed assign-
ment) that is not usable.

Animation File Size
Animation files cannot be larger than 175 MB when converted to the 
Maestro internal file format (.mim). Due to variations in compression and 
other factors, such as the animation size on the screen and the video 

Table 2.  New Maestro Automation Commands

Maestro Automation Command Description

MAESTRO_CONTENT_FILENAME_ASSOCIATION Associates a Content File with an Automation Input Set 
Channel Branding source name.

MAESTRO_CONTENT_FILENAME_ASSOCIATION_CL
EAR_SOURCE

Reverts all Content Files that are associated with an 
Automation Input Set Channel Branding source to the 
default/configured filename.

MAESTRO_CONTENT_FILENAME_ASSOCIATION_CL
EAR_ALL

Reverts all Content Files to the default/configured file-
name.

MAESTRO_CONTENT_PRESENCE Checks for the presence of a Content file.

MAESTRO_CONTENT_REPLACE_TEXT_DATA Replaces the contents of a Channel Branding text data 
with the text string that is contained in the automation 
command.

MAESTRO_TEXT_CRAWL_CONTENT_STATUS Checks the content status of a text crawl on a keyer.
MAESTRO  —  Release Notes 11
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standard, the final compiled version (.mim) may be 60 times larger or more 
than the original file. 

Maestro does not currently have a method for reporting file size before 
loading the file. Manual intervention is required at the Deployment console 
to verify that the compiled version is within the size limitation.

See Appendix B in the 2.2 version of the Maestro Master Control Users Guide 
(Part # 071848204) for example information and formulas that will help 
determine the applicability of the Animation feature in your facility.

Loading an Animation File Larger Than 175 MB

Maestro will internally analyze the file size when a request is made to 
assign the animation file to a key from either the operator or automation. 
Maestro will not assign the animation to the key if the animation is larger 
than 175 MB, when compiled by Maestro (.mim). 

When Maestro cannot assign a file because it exceeds the size limit, it will 
be indicated by the following actions:

• The animation name will not appear on the assigned Key position. 

• An “invalid source” response will be returned for an automation query 
to validate the animation’s assignment.

Using Dynamic Channel Branding
Those using the Dynamic Channel Branding feature will have an addi-
tional complication since the compiled version will not be created until 
Automation submits a request to deploy the animation. Grass Valley rec-
ommends that this creation step be completed well in advance of the 
assigned Play-to-Air time so the file size can be verified prior to Play-to-Air 
assignment.

See Appendix B in the 2.2 version of the Maestro Master Control Users Guide 
(Part # 071848204) for more information.

Spanning Tree Protocol
Using the Spanning Tree protocol or the Rapid Spanning Tree Protocol 
(RSTP) may inhibit communications between the Maestro processor and 
the Deployment PC during startup, especially if communication paths are 
not established within 15 seconds. This communications deterrence can 
result in startup and hot-swap issues and other Maestro network problems. 
All ports should be configured for the auto-negotiate mode. 

The deployment of the Spanning Tree protocol within network switches 
may result in excessive delays before the required communication paths, 
which must be reliable and available, have been established. The Maestro 
12 MAESTRO  —  Release Notes
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Frame Processors and Panel Servers will attempt to communicate with the 
Maestro Deployment PC approximately 15 seconds after a Power On or 
Reset operation. A stable and available communications link is required for 
the boards to function properly. 

Maestro users that make use of the Spanning Tree protocol must assume all 
risk and liability including, without limitation, lost profits, business inter-
ruption, or lost information.

Utilizing the Maximum Amount of Hard Disk Space
The 2.2 version of Maestro uses a 48-bit Logical Block Address (LBA) 
system, which will fully utilize the space on hard disks that are larger than 
137 GB. Software versions prior to the 2.2 version of Maestro employed a 
28-bit LBA system. In other words, if you have a 500 GB hard disk, and you 
do not reformat the hard disk, you will only be able to use 137 GB of the 
available space.

Hard Disk Information

The following information is used to identify the hard disk when format-
ting. Disk numbers can be 0-3. See Table 3 below for more information. For 
more information see Figure 199, on page 294 of the 2.2 version of the 
Maestro Installation manual (part # 071869802)

Reformatting your Hard Disk
There are six steps that you must follow to use the 48-bit LBA system:

1. Install the 2.2 version of the software on to the Deployment PC.

2. Deploy the application’s TAR files to the Frame processor.

3. Format and partition the hard disks.

4. Un-mount and then mount the formatted hard disk

5. Re-deploy the application’s TAR files to the Frame processor.

Table 3.  Hard Disk Information

Location Device ID Disk Number

Bottom left device 0 drive ata0

Top left device 1 drive ata1

Bottom right device 2 drive ata2

Top right device 3 drive ata3
MAESTRO  —  Release Notes 13
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6. Reactivate the preferred Configuration file.

Each of these steps is described in detail below.

CAUTION Grass Valley recommends that you have a back up of the data on the Deploy-
ment PC before you format your hard disks on the Maestro frame. You will 
also need to allow sufficient time to re-cache the media from the Deployment 
PC.

Installing the 2.2 Version of the Software on to the Deployment PC
Follow the steps and caveats listed in the Installing the Maestro Master 
Control on page 20.

Deploying the Application’s TAR Files to the Frame Processor
The new application TAR files must be deployed to the Maestro Frame Pro-
cessors using the Update and Apply button in the Maestro Deployment Center 
application. This deployment will send the new version, which supports 48 
bit LBA, to the Frame Processors.

Follow these steps to deploy the application’s TAR files to the Frame pro-
cessor:

1. Start the Maestro Deployment Control Center application if it is not 
already started.

2. Verify that the Folder field has the correct path to the Maestro 
configuration directory. (The default location is: 
C:\MaestroEmbedded)

3. Select the new TAR file from the Frame Processor Tar File Name drop-
down list.

• Select the MaestroMC_2.20.xxxx.yyy.LTC.tar if you are using 
Linear Time Code. 

• Select the MaestroMC_2.20.xxxx.yyy.VITC.tar if you are using Ver-
tical Interval Time Code. 

4. Select the new TAR file from the Control Panel Tar File Name drop-
down list.

Figure 3.  The Software Application Section - Click Update & Apply
14 MAESTRO  —  Release Notes
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5. Click the Update & Apply button (Figure 3). The update process will then 
begin.

The TAR files that support the 48 bit LBA have been sent to the Frame Pro-
cessors. The hard disk must now be formatted.

Formatting and Partitioning the Hard Disks
You will need to start a Telnet session to the IP address of the Maestro Pro-
cessor board on which the hard disk that is to be formatted is mounted. The 
commands that you will use are:

• altaDiskPart

• dosFsVolFormat

• chkdsk (optional)

You will also need to un-mount and then mount the drive to complete the 
formatting process.

Note It would be best practice to shut down the Maestro Deployment Center appli-
cation and any Maestro Content Management servers to prevent any attempt 
to transfer content while the hard disk is being formatted.

Follow these steps to format and partition the hard disks:

1. Select the board with the hard disk that is to be formatted in the 
Information section, which is below the Software Application and 
Configuration sections. In the example shown below in Figure 4, the 
SWLabHD board was selected.

2. Click the Telnet button in the top right side of the interface (Figure 4). A 
command window with the Telnet prompt will then appear (Figure 5 
on page 16).
MAESTRO  —  Release Notes 15
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Figure 4.  The Maestro Deployment Control Center Application

Figure 5.  The Telnet Session

3. Type devs at the prompt to display all devices. All mounted drives will 
then appear in the list as illustrated in Figure 5.

4. Enter the command: altaDiskPart X at the prompt, where X is the 
ata disk number. The command is case sensitive and must be entered as 
shown in the step above, with the correct disk number instead of the 
“X.” (See Table 3 on page 13 for more information about hard disk 
information.)

A confirmation prompt will then appear. If this prompt does not appear, re-
enter the command.

5. Enter “y” at the confirmation prompt to proceed with partitioning and 
formatting.

When partitioning and formatting is complete, the status information is 
then displayed. See Figure 6 on page 17.

Telnet Button

Selected board
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Figure 6.  Disk Partitioning Command and Status

6. Type dosFsVolFormat X to format the drive.

The CHKDSK Command (optional)

7. Verify the partition and format by entering the following at the 
command prompt (This step is optional): 

chkdsk “/ataX” where X is the ata disk number (0-3) of the disk.

Note The quotation marks around the ata disk designator are required.

Verifying the partition may take a while to complete. After verification, 
information, which is similar to that shown in Figure 7, will be displayed.

Figure 7.  Partition Verification Information

Note Disk verification may cause the Maestro Processor to temporarily lose com-
munications with the Deployment Center. However, channel service is not 
interrupted during the loss of communications.

Repeat these steps for each drive as needed.
MAESTRO  —  Release Notes 17
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Un-Mounting and Mounting a Hard Disk

After formatting a hard disk drive, you will need to un-mount and then 
mount the hard disk to complete the formatting process. The hard disk will 
not work as expected if this step is ignored. See Figure 8 for LED location.

Follow these steps to un-mount and then mount a hard disk:

1. Press the Mount button on the Maestro Main board. The amber Drive 
Mounted LED will flash and then off. 

The hard disk is now un-mounted.

2. Press the Mount Button again to mount the hard disk. 

• The Drive Activity LED will quickly flash green and then the Drive 
Mounted LED will then turn amber. 

Figure 8.  Drive Mount and Activity LEDs 

The drive is now mounted and will work as expected. You must re-deploy 
the TAR file.

Re-deploying the Application’s TAR files to the Frame Processor
Now that the disks are formatted and contain nothing, the Application TAR 
file should be redeployed using the Update Only button in the Software 
Application section of the Maestro Deployment Center application. 

Follow the steps listed in the Deploying the Application’s TAR Files to the 
Frame Processor on page 14 to re-deploy the application’s TAR files to the 
Frame processor.
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Reactivating the Preferred Configuration File
The reactivation of the preferred Configuration file must be completed 
using the Update and Apply button in the Configuration section of the Maestro 
Deployment Center application. 

Follow these steps to reactivate the preferred Configuration file:

1. Start the Maestro Deployment Control Center application if is not 
already started.

2. Verify that the Folder field has the correct path entered. (The default 
location is: C:\Thomson)

3. Select the preferred configuration file from the File drop-down list.

Figure 9.  The Software Application Section - Click Update & Apply

4. Click the Update & Apply button (Figure 9). The update process will then 
begin.

The maestro content will now be redeployed to the hard disks.
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Installing the Maestro Master Control

Interoperability Requirements
• Encore router control system version 1.7 or newer, or

• Jupiter router control system version 4.2 or newer when using ES-
Switch on a VM control system, or

• Jupiter router control system version 7.3 or newer when using ES-
Switch on a CM control system, or

• Jupiter router control system 7.5.0 or newer when using ES-LAN on a 
CM control system

Upgrade Requirements
• A period of time where the Maestro system can be taken off-line (exter-

nally bypassed).

• Windows XP (English version-US Edition) with Service Pack 2 or 
greater.

• In order to upgrade the Maestro software, the Maestro configuration 
computer will need access to the Maestro installation CD or down-
loaded installation files.

• Verify the HD licence key with Grass Valley’s Customer Service depart-
ment. See Contacting Grass Valley on page 4 for the contact information 
for your area.

• The configuration from the existing operational Maestro system will be 
used to complete the Maestro upgrade.

• It is recommended that the Maestro Configuration computer be 
upgraded to contain at least 2GB of RAM and have a Core 2 Duo pro-
cessor.

Note It is assumed that the Dual-Channel DVE option has been previously installed 
on the intended system or that no DVE option has been installed. If you have 
the Single-Channel DVE option, do NOT install this software version. For 
more information, see the 1.7 version Release Notes, which can be found on 
the Grass Valley Web site.
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Caveats
• Network issues are the most common cause of problems at customer 

sites. Network installation and configuration must follow Grass Valley 
recommendations. Please refer to the “Network Configuration” section 
in the Maestro Installation and Service Manual (part number: 
071842302).

• All Maestro processors connected to the same Maestro deployment PC 
and comprising a single system (all processors interconnected via the 
same facility and control LANs) must have the same software version 
and configuration deployed to them. Having different software ver-
sions/configurations deployed within a single system is not supported 
and may result in communication incompatibilities and system failure.
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Software Upgrade Procedure

Note For the complete instructions, see the Maestro Installation manual (Part # 
071869801)

Grass Valley recommends that you follow the Software Upgrade procedure 
steps exactly. The Upgrade procedure includes the following steps:

1. Checking the Boot ROM Versions.

2. Making a Copy of the Maestro Configuration File.

3. Installing the Maestro Software Package.

4. Re-compiling the Configuration File.

5. Updating the System Configuration and Software.

6. Checking the GUI Control Panel for Proper LAN Settings. 

7. Updating FPGAs/CPLDs.

Checking the Boot ROM Versions
Before proceeding with the installation of the Maestro system, you must 
verify the boot ROM version that is installed on the Maestro processor 
board. The boot ROM must be updated to the current version or the pro-
cessor board will not boot properly. 

Maestro software versions 1.4 and higher require the Processor and hard-
ware control panel boot ROMs to be current. 

Note Most Maestro processor boards will have the current boot ROM installed. 
Only previous board shipments will have the older boot ROM installed.

Follow these steps to check the Boot ROM Version:

1. Open the Maestro Deployment Control Center window.

2. Select the Processor, in the Deployment column, that you wish to check 
the Boot ROM version. The row for the selected Processor will have a 
dark background. 

3. Right-click on the FPGA version number in the “Running>>” row and 
in the FPGA column, of the selected Processor. 

4. Verify that the date that appears in the “Loaded” column for the boot 
ROM is Dec 14 2006.
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Note If you see an older date or no date at all, the Boot ROM should be updated 
(See the example in Figure 4). Stop the Installation process and then contact 
Grass Valley Technical Support if the Boot ROM is not current.

5. If there is another Processor (channel) in the system, repeat Step 1 
above and following steps. If not, go to Step 6.

6. In the Maestro Deployment Control Center window, select the control 
panel for which you wish to check the Boot ROM version.

For a hardware control panel, this will be a CP Panel Server board. For 
a GUI control panel, this will be a PCI Panel Server board.

7. Right-click on the FPGA version number in the “Running>>” row of 
the selected Control Panel. 

8. Verify that the date that appears in the “Loaded” column for the 
BOOTROM is Apr 19 2006.

Note If you see an older date or no date at all, the Boot ROM should be updated. 
Stop the Installation process and then contact Grass Valley Technical Support 
for update instructions. 

• If the Boot ROM version is current, go to Step 9. 

9. If there is another control panel in the system, repeat Step 6 above and 
the following steps. If all boot ROMs are current, proceed to Installing 
the Maestro Software Package.

Making a Copy of the Maestro Configuration File
Grass Valley recommends you make a copy of your Maestro Configuration 
file. This step will help with a rollback should something go wrong.

Follow these steps to make a copy of the current configuration set:

1. Launch the Maestro Configuration Editor by going to “Start > All 
Programs > Thomson > Maestro Configuration Editor.”

2. Select “File > Open” from the Menu bar to open the current 
configuration set.

3. Select the current configuration file and then click the Open button. 

4. Select “File > Save As” to create a copy of the set. 

5. Add the current version to the name as a suggestion. For example, v17.

6. Select “File > Save As” again to create another copy of the set. 

7. Add the current version to the name. For example, add “v20”. 

8. Close all Maestro applications.
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Note For more information about the Configuration file, refer to the Maestro Con-
figuration Editor section of the Maestro Installation and Service Manual (part 
# 071869801).

Installing the Maestro Software Package
The following instructions show the steps that are needed to install Mae-
stro. The installation process will check if a previous version is installed on 
the computer. You must remove the previous version of Maestro to install 
the latest version. These steps are explained below.

Follow these steps to start the Maestro application installation process:

1. Insert the supplied software CD-ROM into the computer’s CD Drive 
and follow the prompts.

The CD should automatically start the installation process. If not, 
browse to the CD, using Window Explorer, and then click either the 
MaestroInstall.exe icon or the setup.exe icon. 

Note If this is an Initial installation, you may see a message asking if you want to 
install Microsoft .NET Framework. If so, select the Yes button. (The 3.5 SP1 
version of .NET is located on the CD.) 

Automatically Removing the Previous Version of Maestro
When the installation auto runs from the CD, or is started manually by 
running the MaestroInstall.exe file, the previously installed Maestro 
software is automatically detected. You will then be prompted to 
remove the older version of the software before proceeding with the 
installation of the new software.

1. Click the OK button to proceed with removal of the previous software 
version. A new popup will then appear that will show the progress of 
the removal status. 

The Maestro Welcome screen will then appear.

2. Click the Next> button to begin the installation process. The Destination 
Folder screen will then appear. 

3. Click the Next> button to continue the installation process. 

4. Follow the instructions on the following installation screens. Click the 
Next button as needed.

Note It is recommended that all default values be used during the installation.

5. The InstallShield Wizard Completed screen will then appear when the 
installation process is finished.

6. Click the Finish button. The Installation application will then close.
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Maestro Desktop Icon
Three Maestro shortcuts will be displayed on the PC’s desktop as part of 
the installation process. These Icons are, Maestro Configuration Editor, 
Maestro Deployment Center, and Maestro GUI Control Panel. Clicking the 
program’s shortcut will launch that program. 

Note If the installation fails to complete and you see the error message “Error 1001 
-- the specified service already exists,” you may need to manually remove the 
Maestro Jupiter Router Service software. Refer to Manually Removing the 
Maestro Jupiter Router Service Software on page 35.

Re-compiling the Configuration File
It is required that ALL configuration sets that are to be used with the 2.2 
version of the Maestro application be recompiled with the 2.2 Configura-
tion Editor. This requirement includes upgrading from ALL previous ver-
sions of Maestro. Changes have been made to the configuration tables to 
support the 2.2 version’s functionality. Re-compiling the Configuration file 
will perform all necessary additions and modifications to the Maestro con-
figuration file to support version 2.2.

1. Launch the Maestro Configuration Editor by going to “Start > All 
Programs > Thomson > Maestro Configuration Editor.”

2. Select the Maestro configuration set to be re-compiled by going to “File 
> Open > Thomson” and selecting the set.

This should be the configuration set that was created for v2.2 use (see 
Step 6 in the Making a Copy of the Maestro Configuration File section).

3. If the system displays a Validation Report, you must check the 
indicated table(s) and make corrections as indicated.

You can use the links in the Description column to display the table(s).

4. Save the configuration file.

5. Compile the file by going to “File > Compile Channel Data.”

6. Proceed to Updating the System Configuration and Software below.

Note For more information about the Configuration file, refer to the Maestro Con-
figuration Editor section of the Maestro Installation and Service Manual (part 
# 071869801).
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Updating the System Configuration and Software
1. Launch the Maestro Deployment control center by selecting “Start > All 

Programs > Thomson > Maestro Deployment Center.

A Maestro Deployment Control Center window appears.

Other buttons may appear below the table if content has not been defined. 
For example, “Unmanaged Boards” will appear if a board has not been 
defined in the Configuration file.

Note The presence of unmanaged boards indicates the potential of “rogue” boards 
in the system that could potentially cause a conflict and interfere with the 
configured Maestro processors due to disparate software versions or config-
urations. If this is the case, The Network Description table should be updated 
to include all boards in the system and the configuration recompiled and 
redeployed.

If the board hangs or does not come up in a few minutes, press the Reset 
button on the left side of the Serial port on the front edge of the Main board.

2. Click the Show Log button in the lower left-hand corner of the 
application, to provide detailed monitoring of the update process. This 
is an optional step.

3. In the Configuration box: 

• Verify that the Folder field has the correct path to the Maestro con-
figuration directory. (Default = C:\Thomson)

• Select the Maestro configuration set that is to be activated in the 
File: drop-down list.

This file should be the configuration set that was updated and com-
piled for v2.2 (Step 5 on page 25). The background of a compatible 
configuration file (that is, one that was compiled with the current 
version of the Configuration Editor) will be highlighted green in the 
drop-down list.

The Configuration box contains two buttons: Update Only and Update & Apply.

• Update Only - Downloads the selected configuration file to the 
boards, but, does not apply it as the running configuration. 

Note The selected configuration files appears in the “Pending>>” row. The cur-
rently active configuration appears in the “Running>>” rows.

• Update & Apply - Downloads the selected configuration file to the 
boards and applies it as the running configuration. 

4. Click the Update Only button. 

This action will update the contents of the “Pending>>” row in the 
Board Configuration and Active Configuration columns. 
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Note When the Update Only button is clicked, the configuration file does not 
become the active configuration until the Apply Pending button is clicked to 
activate the “pending” configuration.

CAUTION The following step will interrupt the video and audio signals passing through 
the system for approximately one minute. 

5. In the Software Application box:

a. The Folder field should indicate “C:\MaestroEmbedded.”

b. In the Frame Processor Tar File Name field:

--For LTC systems (those using Linear Time Code) select the file that 
has .LTC in the name. For example, 
“MaestroMC_2.200.aabb.ccdd.LTC.tar.” (When used, LTC is con-
nected to pins 43 and 44 of the GPIO connector on the rear panel.)

--For VITC systems (those using Vertical Interval Time Code) select 
the file that has .VITC in the name. For example, 
“MaestroMC_2.2.00.aabb.ccdd.VITC.tar.”

c. In the Control Panel Tar File Name, field, select the .TAR file. For 
example, “MaestroCP_2.200.aabb.ccdd.tar.”

6. Click the Select All button (lower right corner of application).

Alternatively, each board can be updated independently by clicking on 
the “Board Name” field or all at the same time by using the “Select All” 
button.

The Software Application box contains two buttons: Update Only and Update 
and Apply.

• Update Only - Downloads the selected application software to the 
boards, but, does not apply it as the running application. The 
selected application software files appears in the “Pending>>” 
row. The currently active application software appears in the 
“Running>>” rows.

• Update & Apply - Downloads the selected application software to 
the boards and applies it as the running application software. 

CAUTION The following step will interrupt the video and audio signals passing through 
the system for approximately one minute. 

7. Click the Update & Apply button. 

This action will update the contents of the “Running>>” rows in the 
Version columns and activate the application, FPGA and OS code.

Note If the Update Only button is clicked, the software application file does not 
become the active software application until the Apply Pending button is 
clicked. The “pending” software application will then be the active software.
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If the Update Only button was selected, instead of the Update & Apply button, you 
should:

a. Click the Apply Pending button to activate software and any pending 
configuration files.

Note Clicking the Update & Apply button in the respective section (as in step 7) 
will apply any pending updates for that section. Clicking the Apply Pending 
button will apply both the Software and Configuration updates.

8. Verify that the new Configuration and Application versions are 
“Running.”

9. Proceed to Checking the GUI Control Panel for Proper LAN Settings on 
page 29.
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Checking the GUI Control Panel for Proper LAN Settings
Beginning with Maestro software version 1.4, the “Panel Server IP” address 
and the “Local IP” address for the Maestro GUI must now use control LAN 
addresses only. In releases prior to 1.4, the GUI application would connect 
and run over the facility LAN; this is no longer possible in version 1.6.0 and 
later versions.

The following steps should be taken to ensure that the GUI application is 
set for the correct addresses:

1. With Maestro’s GUI up and running, click the Settings button. This will 
open the Application Settings window.

2. Double-click (or select and click the Alter button) the Panel Server IP 
setting. 

3. Specify the control LAN address of the Panel Server card associated 
with the GUI. 

This will switch the view back to the first Application Settings window.

To look up the GUI control LAN address, go to “Maestro Configuration 
Editor > Network Description Table.” Then check the Board Type 
“GUI” row and the “Control LAN IP Address” column.

4. Double-click (or select and press Alter) the Local IP setting. 

5. Select the control LAN address of the PC associated with the GUI. 

This will switch the view back to the first Application Settings window.

To look up the PC control LAN address, go to “Start > Control Panel > 
Network Connections.” Double-click on the card used for the control 
LAN. Then go to Properties > Internet Protocol > Properties.

6. Close the Application Settings window. The GUI should then connect 
and work properly. 

Note If you have difficulty making this change or if the GUI is not functioning prop-
erly after this change, please contact Grass Valley Technical Support (see 
Contacting Grass Valley on page 4).

7. Proceed to Updating FPGAs/CPLDs.
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Updating FPGAs/CPLDs
This section will describe the steps needed to update the FPGAs/
CPLDs on the Processor boards and on the hardware control panel. 
(FPGA = Field Programmable Gate Array. CPLD = Complex Program-
mable Logic Device.)

Updating FPGAs/CPLDs on the Processor Boards

Note Some of the FPGAs on the Processor are updated using the Software Version 
Update and Apply procedure described above. The remaining FPGAs on the 
Processor are updated using the procedure below.

Follow these steps to update the FPGAs/CPLDs on the Processor boards: 
(see Figure 4 on page 16. for the following steps)

1. In the board Status section of the Maestro Deployment control center, 
select the Processor to update.

2. Right-click on the “Running” FPGA field for this Processor. 

The FPGA/CPLD update menu will then appear. 

This menu shows the names of all of the FPGAs/CPLDs on the Pro-
cessor and the version number of the gateware that is currently 
running (or is loaded) in each device. All of the CPLD-type compo-
nents (and specific FPGA-type components) can be updated using 
the FPGA/CPLD update menu. The menu will indicate the new 
version number and will display a check box when a newer (or cur-
rent) version of gateware is available for those components. 

Note A Current version may have a smaller number than the corresponding Loaded 
version. If FPGA/CPLD updates were performed with prior Maestro software 
versions, there may be no available FPGA/CPLD updates with the current ver-
sion.

3. Check the “Select All” box if there are available updates.

Note Do not check “Gennum A” or “Gennum B” if no DVE board is installed. Doing 
so will cause the update to fail.

4. Select Update.

You will be asked to confirm the update.

CAUTION The following step will interrupt the video and audio signals passing through 
the system. 

5. Click the Yes button.
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6. From this point there are two possibilities:

• A popup will show that the Processor update was successful. 

• An error message may indicate that the “physical JTAG chain is 
broken.” If this message appears, the FPGAs/CPLDs on the Pro-
cessor cannot be updated. Stop the installation process and then 
contact Grass Valley Technical Support (see Contacting Grass 
Valley on page 4).

Updating FPGAs/CPLDs on the Hardware Control Panels
Follow these steps to update the FPGAs/CPLDs on the Hardware Control 
panels

1. In the board Status section of the screen, select the hardware control 
panel to update.

2. Right-click on the FPGA field for this control panel. The FPGA/CPLD 
update menu will then appear. 

This menu shows the names of all FPGAs/CPLDs on the control panel 
and the version number of the gateware now running (“loaded”) in 
each device. Certain FPGA-type components and all of the CPLD-type 
components can be updated using this menu, and if a newer (“current”) 
version of gateware is available for those components the menu will 
indicate the new version number and display a check box. 

3. Check the “Select All” box.

4. Select Update. You will be asked to confirm the update.

CAUTION The following step will cause the control panel to become inoperative while 
the update is in progress. 

5. Select Yes. From this point there are several possibilities:

• A popup will show that the control panel update was suc-
cessful. Repeat the process for additional control panels. When 
all FPGAs/CPLDs have been updated, the upgrade is complete.

• An error message may indicate that the “physical JTAG chain is 
broken.” The CP Panel Server board, which is located within the 
control panel, may need to be replaced. Please contact Grass 
Valley Technical Support to arrange the replacement.
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Configuration

Required Encore Configuration 

CAUTION Portions of this procedure will interrupt video and audio signals passing 
through the system. Users of this equipment should consult with Grass 
Valley Technical Support personnel before proceeding.

For Encore-controlled Maestro systems, it is possible for Encore (prior to and 
including version 1.7.3.1) to run out of TCP/IP sockets. When this happens, 
Encore will refuse any additional Native Protocol client connection 
requests from Maestro processors. This issue usually occurs after the 
Maestro processor has been rebooted many times as part of the software 
update, hardware installation and troubleshooting processes. 

Follow these steps to resolve this issue: 

1. In the Encore OUI, select the Panel Server application

2. Select “RCL Server.”

3. In the “Ethernet RCL Client” section, select a Maestro processor.

4. Select “Flags and Parameters.”

5. For Encore versions prior to and including version 1.7.3.1, set the Refresh 
Rate setting to “60.” For all later versions of Encore, set the Refresh Rate 
setting to “0.”

6. Repeat steps 3-5 for any additional Maestro processors.

When finished setting the refresh rate on all Maestro processors, return to 
the Panel Server page and click on “Modify” to save changes. 

Hardware Upgrade Procedure

Note For the Hardware Upgrade instructions, see the Maestro Installation and 
Service Manual (Part # 071869801)
32 MAESTRO  —  Release Notes



Other Installation Steps
 

Other Installation Steps
These steps are for Jupiter users and if you choose to install Maestro man-
ually.

Installing the Maestro Jupiter-Router Service
The Maestro Jupiter-Router Service must be installed on the Jupiter PC if 
you are using the Jupiter Control system. This process is similar to 
installing the Maestro Software.

Follow these steps to start the Maestro Jupiter-Router Service installation 
process:

1. Insert the Maestro software CD-ROM into the computer’s CD Drive 
and follow the prompts.

The CD should automatically start the installation process. If not, 
browse to the CD, using Window Explorer, and then click the Mae-
stroInstall.exe icon. 

The Maestro Welcome screen will then appear.

2. Click the Next> button to begin the installation process. The Destination 
Folder screen will then appear. 

3. Click the Next> button to begin the installation process. The Setup Type 
screen will then appear.

4. Click the Custom radio button and then click the Next> button.

5. Click the drop-down arrow and then select the This feature will not be 
available option for all of the features except for the Jupiter Router 
Service. A red “x” will appear by the features. 

6. Click the Next> button. The Ready to Install the Program screen will then 
appear.

7. Click the Install button. The installation process will then begin. The 
InstallShield Wizard Completed screen will appear when the 
installation process is finished.

8. Click the Finish button. The Installation application will then close.
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Manually Removing the Previous Version of Maestro
The previous version of Maestro software must be uninstalled before a new 
version can be installed. 

CAUTION If you are uninstalling v1.3, v1.4, v1.5, or v1.5.1 software, you must use the 
Administrator account (login). If you are uninstalling v1.2 or prior software, 
you must use the account (login) used when that software was installed.

Follow these steps to manually remove the previous version of Maestro:

1. Using the Windows Control Panel, select Add or Remove Programs.

2. Select the Maestro Software Package. 

3. Click the Remove button. This step will not remove user data.

4. Close the Windows Control Panel.

The previous version of Maestro software can also be automatically 
removed by starting a new software installation procedure.

Manually Installing Maestro
The installation process can be started manually if it does not start auto-
matically. Follow these steps to manually install the Maestro Software 
Package: 

1. Select the Run command from the start menu( Start> Run).

2. Enter “E:\MaestroInstall.exe” where E: is the CD Drive.

Note If you enter E:\setup.exe (where “E” is the name of the PC’s CD ROM) in the 
Run dialog box (instead of ‘MaestroInstall.exe”) the dialog will appear. Click 
the OK button. The prior Maestro software version must then be manually 
removed using the Add/Remove Programs in the Windows Control Panel. 

3. Click the OK button. The installation as described in the Installing the 
Maestro Software Package section will then begin.
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Manually Removing the Maestro Jupiter Router Service Software
Only perform this procedure if you see the error message “Error 1001 -- the 
specified service already exists” referred to in the Note on page 25.

1. Select the Services by navigating to Control Panel > Administrative 
Tools > Services.

2. Select the Maestro Jupiter Router Service option 

3. Select Stop the service or right click the service and select Stop ().

4. Go to “Start > Run” and enter the phrase “regedit” in the text field 
(fig).

Figure 10.  Regedit example 

5. Go to “HKEY_LOCAL_MACHINE > SYSTEM > CurrentControlSet > 
Services.”

6. Highlight the MaestroJRService and then right click and delete this 
item.

7. Close all windows and reboot. Repeat Step 1 above and confirm that 
the MaestroJupiterRouterService is not listed.

Proceed with the installation proceedure (see Installing the Maestro Software 
Package on page 24).
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